Recherche MFT prend plusieurs semaines!

Utiliser TestDisk pour réparer le système de fichier
Message
Author
Jamie
Posts: 11
Joined: 19 Jul 2019, 14:37

Recherche MFT prend plusieurs semaines!

#1 Post by Jamie » 20 Jul 2019, 07:55

Bonjour,

J'ai suivie les instructions pour reconstruire le NTFS Boot Sector. Test Disk est maintenant rendu à l'étape de la recherche du MFT, ça progresse mais ça fait maintenant plus
de 2 semaines que la recherche a lieu. Le disque est de 4TB et je suis sur un Live CD d'Ubuntu. Au rhytme que ça avance la recherche semblera se compléter dans plusieurs semaines encore. 1202388992/7814037168 jusqu'à maintenant... Est-ce normal?

Le fichier log est complètement vide. J'ai installé plusieurs utilitaires et je pense que c'est à cause qu'il n'y a plus de place en ram pour la création du fichier log... Le système ne cessait de m'envoyer le message qu'il n'y avait plus de place sur le disque.

Voici la genèse de comment que j'en suis arrivé là:

1. J'ai sélectionné le disque en question qui est branché directement en SATA
2. [EFI GPT] EFI GPT partition map (Mac i386, some x86_64...) = Le partition table type choisit automatiquement
3. Analyse n'a reconnu aucune partition
4. J'ai fait le [Quick Search] suggéré et aucun résultat non plus
5. J'ai fait le [Deeper Search] et aucun résultat non plus
6. J'ai sélecitonné [Quit]
7. Je suis allé dans [Advanced] et ça m'a retourné No partition available
8. J'ai sélectionné [Quit]
9. J'ai sélectionné [Quit] Return to disk selection
10. J'ai resélectionné le disque en question
11. Cette fois-ci j'y suis allé avec [Intel] Intel/PC partition comme partition table type
12. Analyse m'a ramené Partition: Read error
13. J'ai fait un [Quick] search et ça m'a retourné aucune partition
14. J'ai fait un [Deeper Search] et ça ne m'a retourné aucune partition
15. J'ai sélectionné Enter: to continue
16. Je suis allé retourné au menu disk selection et cette fois-ci j'ai sélectionné [None] comme partition table type
17. Cette fois-ci Analyse m'a retourné une partion "P Unknown" avec l'option [Quick Search]
18. J'ai eu a fermer la fenêtre car après avoir sélectionné [Quick Search] ça restait à ne rien faire pendant près d'une heure
19. J'ai recommencé de l'étape 16 mais cette fois-ci je suis allé dans Advanced et cet écran s'est présenté
Image
20. En sélectionnant
  • ça m'a retourné Can't open filesystem. Filesystem seems damaged.
    21. J'ai essayé de créer une image, mais l'image finit par être de 0 bytes
    22. J'ai finit par sélectionner [Boot], ce qui m'a retourné cet écran
    Image
    23. J'ai sélectionné [Rebuild BS]
    24. La recherche du MFT a suivit
    25. Maintenant ça fait plus de 2 semaines que la recherche a lieu

    Merci d'avance pour toutes informations qui pourraient clarifiées qu'est-ce qui se passe.

Sponsored links

User avatar
cgrenier
Site Admin
Posts: 4934
Joined: 18 Feb 2012, 15:08
Location: Le Perreux Sur Marne, France
Contact:

Re: Recherche MFT prend plusieurs semaines!

#2 Post by cgrenier » 21 Jul 2019, 18:37

Vous avez forcé le type de table de partition en None, puis forcé le système de fichier en NTFS.
Cela ne sert à rien de faire un RebuildBS lorsque l'on ne travaille pas sur une vrai partition NTFS (!= partition forcée en NTFS).
Le type de table de partition est sans doute EFI GPT comme détecté automatiquement.
En l'état, vu que Quick Search et Deeper Search n'ont rien retrouvé, essayez PhotoRec en choisissant un disque assez gros en destination pour y stocker les données récupérées.

Jamie
Posts: 11
Joined: 19 Jul 2019, 14:37

Re: Recherche MFT prend plusieurs semaines!

#3 Post by Jamie » 21 Jul 2019, 20:17

Daccord, je vais arrêter la recherche du MFT, rebooter et utiliser PhotoRec... Je vous garde au courant de la suite.

Merci.

Jamie
Posts: 11
Joined: 19 Jul 2019, 14:37

Re: Recherche MFT prend plusieurs semaines!

#4 Post by Jamie » 22 Jul 2019, 07:05

PhotoRec est maintenant en marche et après 10 minutes aucuns fichiers ne sont récupérés.... Est-ce normal? Le temps estimé pour compléter la passe est de 57 heures....

Code: Select all

Pass 0 - Reading sector 237041286/7814037168, 0/10 headers found
Estimated time 0h11m18s - Estimated time to completion 57h02m19

recuperation
Posts: 297
Joined: 04 Jan 2019, 09:48
Location: Hannover, Deutschland (Germany, Allemagne)

Re: Recherche MFT prend plusieurs semaines!

#5 Post by recuperation » 22 Jul 2019, 12:28

Jamie wrote:
22 Jul 2019, 07:05
PhotoRec est maintenant en marche et après 10 minutes aucuns fichiers ne sont récupérés.... Est-ce normal?
Non, trouve pas. Mais il est trop tot pour dire quelque-chose.
Jamie wrote:
22 Jul 2019, 07:05
Le temps estimé pour compléter la passe est de 57 heures....
Si on divise les 4TB par 57h on arrive a a-peu-pres 20 MByte/s.
Ca va.

Jamie
Posts: 11
Joined: 19 Jul 2019, 14:37

Re: Recherche MFT prend plusieurs semaines!

#6 Post by Jamie » 22 Jul 2019, 14:18

Daccord, je vais attendre que la passe se complète. Je vous informe du résultat dès qu'elle sera complétée.

Je souhaite faire une copie ddrescue du disque, serait-ce avisé de la faire pendant que PhotoRec est en train de faire sa passe dessus?

Merci.

recuperation
Posts: 297
Joined: 04 Jan 2019, 09:48
Location: Hannover, Deutschland (Germany, Allemagne)

Re: Recherche MFT prend plusieurs semaines!

#7 Post by recuperation » 22 Jul 2019, 15:15

Jamie wrote:
22 Jul 2019, 14:18
Je souhaite faire une copie ddrescue du disque, serait-ce avisé de la faire pendant que PhotoRec est en train de faire sa passe dessus?
Non, parce que ca va causer des mouvements du lecteuer j'assume qui coutent plus de temps que dans le cas ou on fait l'un apres l'autre.
Normalement on commence avec ddrescue surtout s'il y a des secteurs illisibles sur le disque.

Jamie
Posts: 11
Joined: 19 Jul 2019, 14:37

Re: Recherche MFT prend plusieurs semaines!

#8 Post by Jamie » 22 Jul 2019, 15:38

Daccord. Me conseilles-tu d'arrêter la passe, faire la copie ddrescue et ensuite de continuer (présumant que c'est possible avec le fichier photorec.ses...?) la session PhotoRec?

recuperation
Posts: 297
Joined: 04 Jan 2019, 09:48
Location: Hannover, Deutschland (Germany, Allemagne)

Re: Recherche MFT prend plusieurs semaines!

#9 Post by recuperation » 22 Jul 2019, 15:41

Il manque l'etat des parametres SMART pour juger ca.
Un disque deja abime - vaut mieux la copier avec ddrescue comme premiere demarche.

Jamie
Posts: 11
Joined: 19 Jul 2019, 14:37

Re: Recherche MFT prend plusieurs semaines!

#10 Post by Jamie » 22 Jul 2019, 16:39

Voici ce que

Code: Select all

sudo smartctl -o off -s on -S on -T permissive -a /dev/sda
retourne:

Code: Select all

=== START OF INFORMATION SECTION ===
Device Model:     ST4000DM000
Serial Number:    ZDH1D103
LU WWN Device Id: 5 000c50 0a2c7a271
Firmware Version: 0001
User Capacity:    4,000,787,030,016 bytes [4.00 TB]
Sector Size:      512 bytes logical/physical
Rotation Rate:    7200 rpm
Device is:        Not in smartctl database [for details use: -P showall]
ATA Version is:   ATA8-ACS T13/1699-D revision 4
SATA Version is:  SATA 3.0, 6.0 Gb/s
Local Time is:    Mon Jul 22 03:15:29 2019 EDT
SMART support is: Available - device has SMART capability.
SMART support is: Enabled

=== START OF ENABLE/DISABLE COMMANDS SECTION ===
SMART Enable failed: scsi error device not ready

SMART Enable Attribute Autosave failed: scsi error device not ready

A mandatory SMART command failed: exiting. To continue, add one or more '-T permissive' options.
Et voici ce que

Code: Select all

sudo smartctl -o off -s on -S on -T verypermissive -a /dev/sda
retourne:

Code: Select all

=== START OF INFORMATION SECTION ===
Device Model:     ST4000DM000
Serial Number:    ZDH1D103
LU WWN Device Id: 5 000c50 0a2c7a271
Firmware Version: 0001
User Capacity:    4,000,787,030,016 bytes [4.00 TB]
Sector Size:      512 bytes logical/physical
Rotation Rate:    7200 rpm
Device is:        Not in smartctl database [for details use: -P showall]
ATA Version is:   ATA8-ACS T13/1699-D revision 4
SATA Version is:  SATA 3.0, 6.0 Gb/s
Local Time is:    Mon Jul 22 03:17:42 2019 EDT
SMART support is: Available - device has SMART capability.
SMART support is: Enabled

=== START OF ENABLE/DISABLE COMMANDS SECTION ===
SMART Enable failed: scsi error device not ready

SMART Enable Attribute Autosave failed: scsi error device not ready

Read SMART Data failed: scsi error device not ready

SMART Automatic Timers not supported

SMART Disable Automatic Offline failed: scsi error device not ready


=== START OF READ SMART DATA SECTION ===
SMART Status command failed: scsi error badly formed scsi parameters
SMART overall-health self-assessment test result: UNKNOWN!
SMART Status, Attributes and Thresholds cannot be read.

Read SMART Log Directory failed: scsi error device not ready

Read SMART Error Log failed: scsi error device not ready

Read SMART Self-test Log failed: scsi error device not ready

Selective Self-tests/Logging not supported

Post Reply

Who is online

Users browsing this forum: No registered users and 3 guests