Page 1 of 1

Undelete from dashcam sdhc card does not work

Posted: 23 Oct 2015, 10:03
by carla
It is a 32GB micro sd-card with one partition.
There was a DCIM/100MEDIA/ directory that was accidentally deleted.
It contained a lot of .mov and .nmea files.
Since nothing was written on the card after deletion copying the files with testdisk undelete
worked without errors . The directories, file names sizes and dates looked as expected, but the .mov
files did not play and the .nmea files that should be text files contained unreadable binary data.
So I assume testdisk did calculate the location of the data wrong.
I tried undelete+ in Windows but the result is similar : everything looks o.k but
the files contain garbage.

I used linux testdisk /dev/sde1 to do the above things

When I use testdisk /dev/sde I get:
current partition structure:
Partition Start End Size in sectors

Warning: number of heads/cylinder mismatches 255 (FAT) != 64 (HD)
Warning: number of sectors per track mismatches 63 (FAT) != 32 (HD)
1 * FAT32 4 0 1 30171 63 32 61784064 [MEDIA]

Warning: Bad starting head (CHS and LBA don't match)