Recover Files from Android

Using TestDisk to undelete files
Forum rules
When asking for technical support:
- Search for posts on the same topic before posting a new question.
- Give clear, specific information in the title of your post.
- Include as many details as you can, MOST POSTS WILL GET ONLY ONE OR TWO ANSWERS.
- Post a follow up with a "Thank you" or "This worked!"
- When you learn something, use that knowledge to HELP ANOTHER USER LATER.
Before posting, please read
Posts: 2
Joined: 07 Aug 2016, 22:52

Recover Files from Android

#1 Post by aehlayel »


My phone went crazy on me a while ago during travel, and did a factory reset - wiping all information with it on the way..
I've been trying ever since to recover the files that have gone missing, but I don't seem to be able to make it work with testdisk. Something isn't working.

I'm able to dump the mmcblk using the command below:
adb shell su -c "cat /dev/block/mmcblk0" > mmcblk0.raw
I can see the 62G file that's created. I even see partitions.
That's where the fun ends.
When I choose "Analyze" to search for tables. I see all the partitions. Selecting the data partition, the one with all the files I want to recover - I see the below:

Disk e:\mmcblk0.raw - 62 GB / 58 GiB - CHS 7608 255 63
Analyse cylinder 230/7607: 03%

Until it completes 100%. No partitions found. Deep search. Same thing.

Any thoughts or suggestions on how to proceed with this?

Sponsored links

User avatar
Site Admin
Posts: 5330
Joined: 18 Feb 2012, 15:08
Location: Le Perreux Sur Marne, France

Re: Recover Files from Android

#2 Post by cgrenier »

Try PhotoRec on each partition.
Good luck

Posts: 2
Joined: 07 Aug 2016, 22:52

Re: Recover Files from Android

#3 Post by aehlayel »


Thanks for the suggestion. I've just tried it - i get a lot of txt files. However, when I filter for JPG files only, I get the following:
I've tried this for both Data partition, and whole partitions on PhotoRec:

PhotoRec 7.0, Data Recovery Utility, April 2015
Christophe GRENIER <>
Disk e:\mmcblk0.raw - 62 GB / 58 GiB (RO)
Partition Start End Size in sectors
Unknown 0 0 1 7607 174 5 122217421 [Whole disk]

0 files saved in /testdisk-7.0/63/recover/recup_dir directory.
Recovery completed.

Any thoughts?