Page 1 of 1

Files undeleted (TestDisk) but are all corrupted

Posted: 27 May 2019, 20:01
by larsthomsen
Hi all,

So I ran TestDisk and 100.000+ files were undeleted to an external drive. Looking at it, all seems normal... filenames, extensions, date of last change, size, etc...
I just can open any of them. Many are .pdf or .docx and no of the viewers/editors I have will open the files.

Have I done something wrong during the extraction or is there some trick to get it all un-corrupted?

Afterwards I tried running PhotoRec on the same disk on the unallocated space. It gave me half the files in a bunch of folders, some working... sadly not the ones I really need!

... and now the sad story that started it all. I delete a user account on a windows 10 system but didn't save the data first :(

Hope someone has some insights!

Thanks in advance,

Re: Files undeleted (TestDisk) but are all corrupted

Posted: 28 May 2019, 06:06
by cgrenier
Try latest 7.1-WIP version. WHile running PhotoRec, enable the Expert mode in Options, start the recovery and choose a blocksize of 512 bytes, use the default options otherwise.
Does it recover your missing files this way ?