Unable to detect partitions on a HP SmartArray RAID

How to use TestDisk to recover lost partition
Forum rules
When asking for technical support:
- Search for posts on the same topic before posting a new question.
- Give clear, specific information in the title of your post.
- Include as many details as you can, MOST POSTS WILL GET ONLY ONE OR TWO ANSWERS.
- Post a follow up with a "Thank you" or "This worked!"
- When you learn something, use that knowledge to HELP ANOTHER USER LATER.
Before posting, please read https://www.cgsecurity.org/testdisk.pdf
Post Reply
Posts: 2
Joined: 10 Jul 2018, 22:04

Unable to detect partitions on a HP SmartArray RAID

#1 Post by cjj1977 » 10 Jul 2018, 23:00


I am trying to recover lost partitions on a HP Microserver (Gen8) server. The only internal disks are 4x 750GB HDDs configured as one logical RAID device using the built-in "BIOS" HP Smart Array Configuration Utility. I used this to set up the disks in a mirrored striped pair (0+1), total size 1.4TB. This device was divided into logical partitions for a CentOS 7.x installation. Be aware that the B120i SATA RAID controller in this device does not offer "full hardware" RAID; the Smart Array utility appears to just mark the disks according to the RAID configuration and then hand over the work to a software driver (HPVSA). For my CentOS install I had to slipstream this driver during installation.

After a kernel upgrade & reboot the RAID was no longer visible and the system would not boot beyond GRUB. I was able to enter the BIOS Smart Array Configuration Utility to confirm that the RAID was present and healthy. Sadly, I think I managed to trash my MBR & partition table when using those same HP BIOS utilities. :'(

So, I have fired up CentOS 7.4 in "rescue" mode with a compatible HPVSA driver and I can see the logical device once again, but no partitions. I have tried to use Testdisk to detect partitions but, after some initial excitement, it hasn't been able to work out the correct partition structure. I'm afraid I don't know enough about disk geometry to have made much of an attempt to use the advanced CHS options.

My question is whether this sort of fake RAID is throwing off Testdisk. I suspect there is something wrong going on as I have also tried PhotoRec and it is only offering me file fragments: for example the MP3s recovered are all 10 seconds long and duplicated, but otherwise are playable. I'm happy to follow up on PhotoRec as a separate thread, but my gut feeling is that there is one underlying problem that means Testdisk & PhotoRec aren't able to read the RAID in the necessary manner. The duplicate file fragments make me wonder if I'm getting data from both sets of the mirrored disks, or if the RAID is being treated as JBOD, etc.

Has anyone seen this? Is anyone able to explain what is going on? And, crucially, is there anything I should try in order to get these utilities to read the disks correctly?

Sponsored links

User avatar
Site Admin
Posts: 4292
Joined: 18 Feb 2012, 15:08
Location: Le Perreux Sur Marne, France

Re: Unable to detect partitions on a HP SmartArray RAID

#2 Post by cgrenier » 11 Jul 2018, 06:38

I don't know the device name of your smart array RAID. Does testdisk let you choose the correct device ?
If it's not the case, run "testdisk /dev/correct_device".

Posts: 2
Joined: 10 Jul 2018, 22:04

Re: Unable to detect partitions on a HP SmartArray RAID

#3 Post by cjj1977 » 11 Jul 2018, 23:19

When the HPVSA driver is loaded, I can work out which device it is using lsblk or fdisk -l. Generally I see it as /dev/sdc. At the moment when I run those tools I also see 2x partitions as /dev/sdc1 and /dev/sdc2.

I'm able to select the same device when TestDisk runs, and the total size of the device is correctly reported as 1.4TB. I have tried detecting partitions a few times, and every time it seems to find loads of partitions (10 or more), none of which seem to be realistic. I'm expecting no more than the usual 3 partitions for a Linux installation (/, /boot & swap) plus one extra partition for /home.

Post Reply

Who is online

Users browsing this forum: No registered users and 4 guests