Partition Read Error

How to use TestDisk to recover lost partition
Forum rules
When asking for technical support:
- Search for posts on the same topic before posting a new question.
- Give clear, specific information in the title of your post.
- Include as many details as you can, MOST POSTS WILL GET ONLY ONE OR TWO ANSWERS.
- Post a follow up with a "Thank you" or "This worked!"
- When you learn something, use that knowledge to HELP ANOTHER USER LATER.
Before posting, please read
Post Reply
Posts: 2
Joined: 10 Jun 2021, 18:38

Partition Read Error

#1 Post by lirasus »


I have some troubles with my external HDD (500 GB), which did not start anymore and windows always wanted to initialize it.

Therefore i read through many topics and I used Testdisk:

I did the following steps:
Chose the Disc - [Intel ] - Analyse:
No partition was found and message "Partion Sector Doesn't have the endmark 0xAA55" was displayed.

So I performed a quick search and after 1 s my partition was found. I changed it from * to "p" and pressed "write".

After a restart the windows-explorer showed me the HDD again and everything seemed to be fine:
But now I can't open/or copy any data from there and it alway takes some seconds to open a folder or to open a folder is not even possible ("the request could not be performed because of an i/o device error")

When I use TestDisk now and use "Analyse" it shows me: "Partition Read error" (I again used chose [Intel] here even though it suggests "none"?)

Did I do something wrong? What can I do next?

Unforntunately the log-file was already overwritten.

Thanks for your help!

Posts: 1604
Joined: 04 Jan 2019, 09:48
Location: Hannover, Deutschland (Germany, Allemagne)

Re: Partition Read Error

#2 Post by recuperation »

Try duplicating the drive as described in the manual using ddrescue.

Posts: 2
Joined: 10 Jun 2021, 18:38

Re: Partition Read Error

#3 Post by lirasus »

Thanks for the answer.

Today after reconnecting it suddenly worked and I could copy my data to an other drive. Strange because I did not change anything but nvm. :D

Post Reply