Page 1 of 1

"Write Error" error

Posted: 18 Mar 2012, 22:57
by Necroman
Hi there!

I have used Testdisk many times to mainly recover partitions that became unavailable on Windows PC's. This time it happened with my USB 1TB hdd that have lost of important info!

The partition shows as RAW on Windows disk management and Windows wants me to format it when i try to access it. I really don't know how this happened because i securely removed the hdd the last time i used it.

Nevertheless, i used testdisk and the same disk appears 3 times. I choose the one that stated "dev/sdd", intel for the partition table (it was formatted as NTFS in Windows 7), analyse, quick search and testdisk shows me the correct partition with my files in it. But when i try to write the partition i got an "Write error" error and i can't do anything else!

I'm now running a deeper search but i'm afraid i could have the same problem at the end! Is there anything else i can do to recover the partition?

PS: Since Testdisk shows me the disk 3 times, if i try other ones i got strange partitions and if i try to go next, Testdisk starts scanning with huge numbers, but i never got to the end...

Please help!! Many thanks!

Re: "Write Error" error

Posted: 19 Mar 2012, 10:15
by Fiona
Can you upload the testdisk.log?
The file type *.log it's not supported for upload but you can zip or rename it to testdisk.txt.
Also you can open it using wordpad and copy the content.

Do you have any background processes running, which prevents TestDisk to write?
Could be Antivirus, Security Suite, Norton GoBack - Sonar...

Also can you check that your external disk using hardware encryption?
We've got a couple of cases. ... .html#p814

Re: "Write Error" error

Posted: 19 Mar 2012, 14:57
by Necroman

I'm sure the disk is not encrypted, as i can see the files and folders on both Testdisk and Photorec.

I'm sending the log regarding the hdd directly connected to a SATA port, as i removed it from the USB external case just to see if i could recover it. I will send the log regarding the disk connected to USB later.

I only have Microsoft Security Essentials as anti-virus and i'm using Windows 8 CP. I have also tried on other computer running Windows 7 with Microsoft security Essentials and on both computers i got a "Write Error" error.

I have sucessfully run chkdsk /f and it fixed several errors on the partition, but i'm still unable to access it on Windows, as it gives me an error while accessing it.

After i did that the disk management no longer shows the disk as RAW and i can see the label on Explorer, but i still can't access the disk files and folders. Now with the hdd directly connected to SATA port it's even stranger, because i see 2 different partitions that i didn't have - but maybe it has to do with the special OEM partition, as its a hdd from Iomega and it has a special partition with Iomega software...

Re: "Write Error" error

Posted: 19 Mar 2012, 15:47
by Necroman
Great news!!

I ran chkdsk, the disk was analised and it fixed some errors, the label was shown on Explorer but when acessing the disk i got an "Access denied" error. I then remembered the security options of File and Folder Permissions!!

I have fixed the problem by changing ownership of every file and folder on the disk, and previously done a chkdsk!

Testdisk was unable to help me this time, but its always an excellent tool and it helped me as a diagnosis tool!

Thanks again for your help and the excellent piece of software!

PS: I think i just panicked because of the important files i had on the disk :D
Also i think the "Write Error" error was because of the file and folder permissions... Hope this helps someone!

Re: "Write Error" error

Posted: 19 Mar 2012, 19:15
by Fiona
Thanks for your feedback! :)
I'll set your topic as solved!