Page 1 of 2

Disk with wrong Geometry (I think)

Posted: 02 Feb 2013, 22:19
by fixxerlast
Hi all

Here is my story...: I just bought a NAS, and thought i would just take the HDD from my external drive, with all the Data already on it and start with that one.. however, when it asked me to create a volume, i got cold feet, and stopped the process, to empty the data to another disk before using the NAS. When i connected the drive to my computer it could not read it.. like it needed to be formated again. I then ran a Testdisk and i was told the disk seems too small, and from what i can read on this forum, it means the geometry on the disk is wrong.

The disk is a 1,5Tb WD disk. the Deeper search took 12 hours, and unfortunately i did not make a log, but i took a picture of the result, maybe you can use that for something...

Can i change the geometry of the disk without loosing my data? and what do i need to change it to..? if you need a log to help me, let me know and i´ll make another search..!

Re: Disk with wrong Geometry (I think)

Posted: 13 Feb 2013, 11:52
by fixxerlast
Is this a very hard nut to crack or is the forum here not very active?

It seems like the people replying on other posts knows what they are talking about, so i hope one of you knows how i can get my data back...

Also, why do i not see the attached picture on my post? i have attached it twice now...

Re: Disk with wrong Geometry (I think)

Posted: 13 Feb 2013, 16:02
by Fiona
Did you upload your attached pictures successful?
If your disk needs to be formatted again, looks like your partition is still in your partition table.
Can you repeat your diagnoes and copy and paste the contetnt of your testdisk.log file?
The file testdisk.log is in your testdisk folder.
Might be ok to get info from testdisk analyse to check your current partition table.
If your partition is still correct in your partition table, you probanly need only a boot sector diagnose.


Re: Disk with wrong Geometry (I think)

Posted: 13 Feb 2013, 16:09
by fixxerlast
Hi Fiona

Thanks for your reply

Maybe the Picture is too big... i have made a smaller version hope it works this time..!

I will run another Deepersearch scan, and this time make a log... I´ll be back tomorrow..!
20130202_214137-small.jpg (164.01 KiB) Viewed 3885 times

Re: Disk with wrong Geometry (I think)

Posted: 13 Feb 2013, 16:56
by Fiona
Now it looks better :O) !
Your partition table only contains a FAT16-Partition and looks wrong?
You should run Deeper Search to have a try to get better results.
If "Deeper Search" finds more partitions, please mark them and press p to have a try to list your data.
To speed up the scanning procedure, if during the scan your partition is listed, you can press F (upper case) to jump to the end of the partition.
Mostly recognized if the label of the partition is displayed.


Re: Disk with wrong Geometry (I think)

Posted: 13 Feb 2013, 17:33
by fixxerlast
The picture it taken from the result of a Deeper search. And yes Fat16 is definitely wrong, i have copied big files onto the disk, (10Gb+) i normally Format all my disks with NTFS, not 100% sure about this one though, since it´s an external disk..

Do you think another Deeper Search may find other results?

And by the way, is there a way to run testdisk from Windows, instead of booting on the disk..?

Re: Disk with wrong Geometry (I think)

Posted: 14 Feb 2013, 15:30
by fixxerlast
Hi again

The Deeper Search is now done, (Same result) however since i ran Testdisk on a bootable disk, there is no log file. (didn't think of that) im now running it again... Be back in 12 hours time :)

Re: Disk with wrong Geometry (I think)

Posted: 15 Feb 2013, 05:51
by fixxerlast
There we go.... i ran Testdisk from a folder and got a log file, however the program was terminated when i woke up this morning... so i didn't get to see the result, and therefore wouldn't have had the ability to do something about the partitions it may have found...

Heres the Log..:

Thu Feb 14 15:33:23 2013
Command line: TestDisk

TestDisk 6.14-WIP, Data Recovery Utility, December 2012
Christophe GRENIER <>
OS: Windows 7 (7601) SP1
Compiler: GCC 4.7, Cygwin 1007.17
Compilation date: 2013-02-11T11:20:27
ext2fs lib: 1.42.2, ntfs lib: 10:0:0, reiserfs lib: 0.3.1-rc8, ewf lib: 20120504
disk_get_size_win32 IOCTL_DISK_GET_LENGTH_INFO(/dev/sda)=1500301910016
disk_get_size_win32 IOCTL_DISK_GET_LENGTH_INFO(/dev/sdb)=120034123776
disk_get_size_win32 IOCTL_DISK_GET_LENGTH_INFO(/dev/sdc)=500107862016
disk_get_size_win32 IOCTL_DISK_GET_LENGTH_INFO(/dev/sdd)=1499598946304
disk_get_size_win32 IOCTL_DISK_GET_LENGTH_INFO(\\.\PhysicalDrive0)=1500301910016
disk_get_size_win32 IOCTL_DISK_GET_LENGTH_INFO(\\.\PhysicalDrive1)=120034123776
disk_get_size_win32 IOCTL_DISK_GET_LENGTH_INFO(\\.\PhysicalDrive2)=500107862016
disk_get_size_win32 IOCTL_DISK_GET_LENGTH_INFO(\\.\PhysicalDrive3)=1499598946304
disk_get_size_win32 IOCTL_DISK_GET_LENGTH_INFO(\\.\C:)=119926685696
filewin32_getfilesize(\\.\D:) GetFileSize err Forkert funktion.

filewin32_setfilepointer(\\.\D:) SetFilePointer err Forkert funktion.

Warning: can't get size for \\.\D:
disk_get_size_win32 IOCTL_DISK_GET_LENGTH_INFO(\\.\E:)=104857600
disk_get_size_win32 IOCTL_DISK_GET_LENGTH_INFO(\\.\F:)=500105217024
disk_get_size_win32 IOCTL_DISK_GET_LENGTH_INFO(\\.\G:)=700448768
disk_get_size_win32 IOCTL_DISK_GET_LENGTH_INFO(\\.\H:)=1500193488896
filewin32_getfilesize(\\.\J:) GetFileSize err Forkert funktion.

filewin32_setfilepointer(\\.\J:) SetFilePointer err Forkert funktion.

Warning: can't get size for \\.\J:
Hard disk list
Disk /dev/sda - 1500 GB / 1397 GiB - CHS 182401 255 63, sector size=512 - ATA WDC WD1502FAEX-0, S/N:WD-WMAY01088728, FW:1D05
Disk /dev/sdb - 120 GB / 111 GiB - CHS 14593 255 63, sector size=512 - ATA OCZ-VERTEX3, S/N:OCZ-29J42OAUXRATO821, FW:2.15
Disk /dev/sdc - 500 GB / 465 GiB - CHS 60801 255 63, sector size=512 - ATA ST3500630AS, S/N:6QG3D9CX
Disk /dev/sdd - 1499 GB / 1396 GiB - CHS 182315 255 63, sector size=512 - WD My Book 1110, S/N:WMAVU3451515, FW:2003
Drive E: - 104 MB / 100 MiB - CHS 12 255 63, sector size=512
Drive G: - 700 MB / 668 MiB - CHS 167 64 32, sector size=2048 - WD Virtual CD 1110, S/N:WMAVU3451515, FW:2003
Drive H: - 1500 GB / 1397 GiB - CHS 182388 255 63, sector size=512

Partition table type (auto): EFI GPT
Disk /dev/sdd - 1499 GB / 1396 GiB - WD My Book 1110
Partition table type: Intel

Analyse Disk /dev/sdd - 1499 GB / 1396 GiB - CHS 182315 255 63
Current partition structure:
No partition is bootable

Disk /dev/sdd - 1499 GB / 1396 GiB - CHS 182315 255 63
Search for partition aborted



No partition found or selected for recovery

Re: Disk with wrong Geometry (I think)

Posted: 19 Feb 2013, 07:44
by fixxerlast
I ran another scan, and this time the program didn't shutdon on it´s own, so i had the opportunity to take action... (same result though)

anyone get something out of this log? what have gone wrong?

Re: Disk with wrong Geometry (I think)

Posted: 22 Feb 2013, 17:28
by fixxerlast
Can anyone help me with this..? im pretty lost, and would realy like to recover the data on that disk... :cry: