Page 1 of 1

MicroSD Card - Partition Lost

Posted: 05 Feb 2013, 00:54
by smsfrancis

My girlfriend's Sandisk 32Gb MicroSD card was within her Samsung Galaxy Ace mobile phone and suddenly one day the card becomes corrupt and loses all data.

I asked various questions and the winning answer seems to be that a magnet was nearby in her bag, but this is not 100% definitely the reason.

Anyway, I've got the card in my PC now and running TestDisk v6.14 on Windows Vista 64 bit.

I have tried various partition testing under Intel, None and some others but the only one that even sees anything is "None". However, it is displaying the size as 32Mb not 32Gb. Might be significant?

Under "None" it also says "Partition sector doesn't have the endmark 0xAA55"

I then read some posts and saw some information on changing the Partition type manually from Unknown to something else to try and fix the Boot record. So I tried FAT16, FAT32 and NTFS... no joy. It says it can't find the cluster size.

It is not vitally important in value, purely in sentimental value. We already have another MicroSD card on its way to us as I do not believe in using storage that has gone through this!

But saying that, we would really like to get some of the holiday photos that were on it back to somewhere safer.

Could someone knowledgeable please give me some tips?

Thank you :geek:

Re: MicroSD Card - Partition Lost

Posted: 10 Feb 2013, 21:25
by zom2moon
I have exactly the same problem, testdisk says that my sandisk 32Gb has a capacity of 32Mb.

It "died" this night when my samsung note stop when the battery was empty (sorry for my english)

I think that a magnet is not the problem, a sd card is not a magnetic device like a hard disk. My phone is alweys in my pocket. I don't think i approach a big magnet. May be static electricity from my clothes but i don't think...

Re: MicroSD Card - Partition Lost

Posted: 12 Feb 2013, 19:31
by NanomasQ

I have kind of similar problem but not quite. In my case when I plug my SD card (32Gb class 10) into the PC slot (win7/64bit) it detects it as an F: drive but tells me that Windows cannot access it. It gives me the option to format. So I start the Testdisk and there I see only my main disk (C drive), nothing more.

I assume this is because when I go to properties of my disk F it says it has zero bytes in both free and used space. The note in testdisk say it must detect the size. Now the question is what I can do in my situation??
Something tells me that information about the disk structure is missing. I had an idea to buy a second exactly the same disk (type and manufacturer) and read out the proper values out of it. Then write the proper "header" information into the corrupt sd card some how. Or rather use virtual header and tell windows some how to use this to access the F drive.
Is this possible? Do I make sense at all?
What are my options?

Many thanks for any imput on the matter.

Re: MicroSD Card - Partition Lost

Posted: 13 Feb 2013, 08:16
by Fiona
@ SMSfrancis

You can try using partition table type None and the menu Advanced / Boot to have a try to rebuild your boot sector (Rebuild BS).
If your partition appears in the menu advanced as Unknown, you can use the menu "Type" to change it to your previous partition type like FAT32 (0c) or NTFS (07).

@ zom2moon

If your sd card only displays 32 MB instead of 32 GB so it looks like that your build in controller might be defective.
Only a professional datarecovery would help.

@ NanomasQ

//I'll remove your crosspost

Did you use TestDisk 64bit?
TestDisk 6.14 32bit is revommended.
How appears your sd card in your windows disk management console?


Re: MicroSD Card - Partition Lost

Posted: 13 Feb 2013, 10:12
by NanomasQ
Hello Fiona,

Thank You for the prompt answer.

Yes I used the 32bit version of the beta Testdrive (6.14).
In Windows Disk Management I can see "Disk 1",
"removable (F:)",
"No Media".
When I open properties and go to Volumes tab, I see: Partition style MBR and Capacity, Unallocated space and Reserved space, all 0 Mb.
No volumes in the window below.

Any suggestions?

Re: MicroSD Card - Partition Lost

Posted: 13 Feb 2013, 22:34
by zom2moon
@Fiona :
Do you know a good free software to backup my sdcard ?

Re: MicroSD Card - Partition Lost

Posted: 16 Feb 2013, 10:33
by smsfrancis
Fiona wrote:@ SMSfrancis

You can try using partition table type None and the menu Advanced / Boot to have a try to rebuild your boot sector (Rebuild BS).
If your partition appears in the menu advanced as Unknown, you can use the menu "Type" to change it to your previous partition type like FAT32 (0c) or NTFS (07).
Right, thank you for the reply. I will go through your steps in stages of "what happened":

1. Use TestDisk 32bit - program finds /dev/sdd 32mb Generic Card Reader <--- this is the card, but wrong size
2. Check in Disk Management - Windows can also see 32mb in a single "RAW" partition which it says is Online & Healthy :roll:
3. Use Partition Table "none" - done
4. Check Advanced - partition found but "Unknown" type. Starts at 001, ends 3 230 3, size in sectors 62688
5. Change partition type - as this is not my card originally, I'm not certain what the partition type would have been. But I changed to FAT32 first, then went to Boot:

"Boot sector Bad, Backup boot sector Bad, Sectors are identical, a valid fat boot sector must be present"
Selected Rebuild BS
"Can't find cluster size"

Try NTFS instead: freezes on Rebuild BS for a moment but doesn't solve anything
Try "Unknown" instead: can only make an image, it does make a 32mb image in 'dd' format. Can't open it but it's too small anyway?

Any more help please?

Re: MicroSD Card - Partition Lost

Posted: 18 Feb 2013, 07:11
by Lito
Hi, digging about this is what I have found.

Sandisk Knowledge Base ... /related/1

Information about recovering card data. You could get one of the trial software packages on offer.

This page: states:

"For miniSD/microSD cards - The cards must be used with a compatible reader before it can be read in the computer."

Therefore you will need a card adapter.
The good news is that they are not expensive.
You can get one in for about two quids.

More tips from Sandisk: ... ter%20size

you are advise to make sure that the card is unlocked. Adapters might also have a lock.

About the original format, note that FAT16 supports a maximum of 4GB (found it in Wikipedia).So your card is not FAT12 or FAT16.

Cards with a size equal to yours (32GB) are preformatted with FAT32.

Bearing in mind that the card was in an Android OS phone, it is possible that the card has been formatted
with one the Linux file systems, either ext2 or ext4.

You can always try cloning the card (two adapters).When you have a clone you can try different things with no risk
of losing the original data.

If you donĀ“t get anywhere with TestDisk, you could try Photorec to save your files.

Sector Inspector might help you ascertaining what is in the card. But it is a command line tool.
To be safe you will have to make sure that you read and understood all options. ... n&id=19470

About "Partition sector doesn't have the endmark 0xAA55 ... es.htm#mbr

Daniel B. Sedory (better known as The Starman) has a wealth of knowledge about HDD and their inner workings in his site.

The Starman pages mention another tool: HxD which is a free Hex Disk Editor.
This tool was also mention by another user, a few days ago.
You could use it to visualize your card, without making any changes.
You could have a go at making changes to a clone. Write down what you change. Or sketch what you plan
doing. It will help you in the long run.

From this place you could get a Rescue Kit:

From this place you can download a Home Edition (freeware) of Partition Wizard

Once you have your bootable CD burned, you can use to copy the whole card to another.
You can also use to see the files your trying to recover.

Best of luck