Page 1 of 1

HFS+ and unmountable Linux partition

Posted: 13 Feb 2013, 18:24
by steveplatz
I used GParted to resize an HFS+ partition on an external disk. There was another Linux partition on the disk, which has been rendered unmountable from this process. When I analyse the cylinder with TestDisk, I'm shown the two partitions, types HFS+ and Linux. The files and directories still exist on the Linux partition, so I would like to simply write the partition structure to disk, but I'm of course getting

Code: Select all

Function write_part_mac not implemented Use pdisk to recreate the missing partition using values displayed by TestDisk
I've tried to change the type of the HFS+ partition to Linux (I really don't care if it's preserved, although I'd like to preserve everything, if possible), but I still get the same output. I actually have a PPC with pdisk, but I don't think using it is the answer here. I can copy the files, but I don't have enough backup space to copy all of them. Can anyone suggest a better method?