Page 1 of 1

Bootcamp/HFS partition crash+disk geometry problems

Posted: 07 Mar 2013, 17:52
by unphazed
Background: MacBook pro 10.8.X. replaced DVD drive with wd blue 5400 rpm 1tb 2.5 inch drive. It has a bootcamp NFTS partition and a HFS partition. Yesterday I turned my computer on and I got "disk you inserted needs to be initialized blah blah blah" shows up in disk utility with 2 unmountable partitions.

When running an analyze with it hooked up internally I get the following pictures. When I try and run quicksearch it hangs and never even shows the percentage/current lba. ... tled4.tiff ... tled2.tiff ... tled3.tiff

I took it out and hooked it up to a Sata to usb converter. After letting it spin up I hooked it up to my mbp. I ran testdisk again and it will run analyze/quicksearch and it won't show either partition (partitions still show in disk utility). I tried changing the heads/sector to get it to read properly but I get continous read errors. I figured at this point it is time to get some expert help.