Page 1 of 1

Wrote "Intel partition" instead of "GPT" am I in trouble?

Posted: 17 May 2013, 05:14
by taboo
Hi all,

I'm running 4x2TB disks off an intel raid chip on my Asrock z68 extreme 4 gen 3 mobo. I had two members missing from a RAID5 array after toggling from RAID to AHCI in the BIOS. My array was initialised in Win7 and is only used for data (no booting).

I have at present deleted the array. Recreated the array with identical settings. Booted into Windows and run testdisk. Testdisk asks for he partition table type and automatically highlights EFT GPT. I stupidly changed it to Intel (thinking it's an intel raid chip). After doing a quick search it would bring up one green partition within a second and at that point I would write the partition structure. I have tried this process multiple times and have written Primary bootable, Primary and Logical. So far I've not been able to get my files showing up.

I'm afraid I may have cause irreparable harm by choosing Intel and then also writing the partition structure multiple times, jumping from primary to logical etc. Last night I ran testdisk again in EFT GPT mode and started the quick search. The next morning it had been running for ~8hrs and only made it to 67%. I've left it running.

Assuming my drives are plugged in the correct order, assuming I deleted and recreated the array correctly and assuming I choose the right partition type (EFT GPT i believe?) how long should test disk take to run?

Thank you so much for any help. This array holds over a decade or irreplaceable photos and music :oops: .

Re: Wrote "Intel partition" instead of "GPT" am I in trouble

Posted: 17 May 2013, 14:12
by Fiona
You should use EFI GPT.
But to write a GPT disk on windows, you must created a gpt disk using your diskmanagement console first, without formatting etc..

First of all, watch your disk management console and your RAID.
In that little left square at the left, is your disk displayed as GPT disk or Basic?
Basic means Intel MBR.
Often windows doesn't display GPT disks correctly.
If your disk is displayed as Basic, please right click in that little square and open your context menu and upload a screen shot.

Normally if both matches, and you have no background process like antivirus running, you should be able to write your partition to your GUID partition table.
Have you been able to list your files?


Re: Wrote "Intel partition" instead of "GPT" am I in trouble

Posted: 17 May 2013, 14:25
by taboo
Ok so, I started again and this time I went into disk management and initialised the disk with GPT. The little box on the left is saying "basic - online" and my right click menu options are "convert to dynamic disk", "convert to mbr disk", "properties" and "help".

What should I do.

Re: Wrote "Intel partition" instead of "GPT" am I in trouble

Posted: 18 May 2013, 01:12
by taboo
For a little more info, here's what I had done before my post above and initialising the disk:

1) Reset disks to non-raid.
2) Build new raid identical to previous one.
3) Booted into windows and used TestDisk to analyze with partition table set to EFI GPT.
4) Quick Search has been fairly unhelpful so I stopped that then did a deep search.
5) Within ~10secs a deeper search showed my array (BackupRaid) along with one or two others:
6) I stopped the deeper search after a minute or two and tried to view files for my BackupRaid. It wouldn't show any files :( .
7) I wrote a new partition table for my BackupRaid anyway and rebooted.
8) After a reboot a new drive would show up but it's not accessible and there are no files on it.
7) RAID 10 partition showed correct files, marked it as primary partition, wrote partition data to disk using testdisk
8) Rebooted
9) Re-established links within windows (and re-installed chrome... for whatever reason that and only that got corrupted in the process... and it wasn't even on the raid to begin with! I was on C! As soon as I reinstalled it, all the bookmarks, extensions, and settings were in place automatically. Whatever)

Also, I've tried running other recovery programs and a couple have been able to list file names that I recognise however any time I've let them scan the drive to completion and list everything they can recover most of it is just random gibberish and corrupted files.

Re: Wrote "Intel partition" instead of "GPT" am I in trouble

Posted: 19 May 2013, 04:06
by taboo
When I do write a partition table as I described in step 7) above and reboot windows immediately tries to do a disk check on boot. At the moment I've cancelled it each time coz I'm afraid it will completely ruin the data on my drives. Should I maybe let it go and see if I can then access my drive after it's done?

Please. Any help is appreciated at the moment.

Re: Wrote "Intel partition" instead of "GPT" am I in trouble

Posted: 22 May 2013, 08:37
by taboo
Still wondering if anyone can answer my above questions.