Page 1 of 1

3TB Seagate HD USB on Win7 64bit - Problem

Posted: 07 Sep 2013, 03:02
by LoungeLizard

I'm having an issue. I have a 3TB Seagate HD partitioned in half (2 partitions approx. 1.3TB each) and formatted NTFS using GPT. It's been working fine for over a year until a couple of weeks ago. I had the drive connected to an older Win2003 server that recognized the physical drive as two drives and loaded a bunch of files onto one of the partitions. I went away for a while, leaving the computer running and drives connected, idle - everything seemed fine. Upon returning however a few days later, I found the computer had rebooted due to a power problem and my UPS did it's job correctly. But, there is now a big problem with my 3TB Hard Drive - it only shows one of the partitions as normal; but the other partition in the Disk Manager shows up as RAW and Windows asks me to format it. Thinking somehow the MFT got corrupt (not thinking it's partitioned as GPT), I ran CHKDSK - only to have it run for a few days before I killed the process. So, I decided to give TestDisk a whirl before I hook this thing up on my Linux Workstation. TestDisk shows the drive as 746GB... WTF??? How do I get Windows 7 64bit OS to recognize this drive correctly so I can try to figure out if my files are still there on the partition that no longer is readable in Windows?

-- Da Lizard

Re: 3TB Seagate HD USB on Win7 64bit - Problem

Posted: 12 Sep 2013, 10:16
by cgrenier
When using TestDisk, choose the PhysicalDrive, not a drive letter.
Can you post screenshots or paste testdisk.log if the problem remains ?

Re: 3TB Seagate HD USB on Win7 64bit - Problem

Posted: 01 Dec 2013, 09:54
by LoungeLizard
OK - it's been a couple of months, I know. Life happens...

Anyway, I still have this problem with that 3TB Hard Drive. I've tried many things but still have no joy. Half the drive is missing. Every time I connect the drive on my Win7 laptop, it responds wanting to format the partition that is missing.

When I run test disk, I am in a terminal-like window. I don't have a drive letter option, I have either my internal 500GB HD on my laptop (showing up as /dev/sda) or the attached Seagate hard drive labeled "Seagate Desktop" (showing up as /dev sdb - see "testdisk snapshot" attached
TestDisk Snapshot drive selection options
TestDisk Snapshot drive selection options
TestDiskSnapshot.PNG (44.71 KiB) Viewed 1164 times
). I don't want to go any further since the drive only shows 746Gb. This is a 3TB HDD running on an Acer Aspire laptop (see "Win7Ult" snapshot
Windows 7 System Data
Windows 7 System Data
Window7UltData.PNG (48.46 KiB) Viewed 1164 times
- it's not that great; but hey it works and does what I need of a laptop). So, while I am giving you views, I'll also show the Window's DiskManager graphic:
Disk Manager View of the drives.  Note the 2nd partition now shows as "RAW" where it used to be formatted as NTFS with a name like '3TB-2ndHalf'.
Disk Manager View of the drives. Note the 2nd partition now shows as "RAW" where it used to be formatted as NTFS with a name like '3TB-2ndHalf'.
DiskManagerView.PNG (31.76 KiB) Viewed 1164 times
Note that Windows Disk Manager DOES recognize the drive as having 3TB (or 2794GB) and that the 2nd partition shows as RAW type.

I have done a lot of research and it appears perhaps I was misled on 3TB drives. Apparently, I am a victim of the >2TB issue that so many have encountered with these 'larger' drives. It's like deja vu all over again...

In the meantime, I acquired a couple of 2TB drives to off-load the data that I can see. So I have a copy of the 1st Half that I can access and it seems the files there, at least, are intact. I plan to hook up the drive eventually to my Linux box and try to image the lost side to see if I can recover anything. The problem with the Linux box might be that it is an AMD system and may also have an issue with the >2TB boundary.

So, any help beyond what I'm trying to do?

--Da Lizard