Page 1 of 1

Data Drive accidentally formatted

Posted: 02 Dec 2013, 16:47
by zhengfu23
Hi everyone, thanks for viewing. Let me first explain how I got to this annoying place.
* I was trying to install linux mint on my PC last week, I have 4 SATA ports on my motherboard and at the time of installation, I thought I had my target 128GB SSD at SATA port 2 and my data 2TB HDD at SATA port 3 and proceeded with the installation. However, as I was on the page to choose whether to install along side an existing partition on the same drive or format a drive to install as new, I wasn't ask for a choice as to which disk I should install to, but I went ahead anyways because I thought it might prompt later. (yeah stupid :( ) However after clicking continue with format the drive, I realize the process has already begun and then I realized there's a problem. My 128GB SSD appears not to be connected. So after about 2-3 seconds I force shut down the machine by cutting the power so the formatting should only proceeded for that 2-3 seconds. So then when I try to boot into my original windows partition on a 256GB SSD on SATA port 1 I found the 2TB drive has disappeared in my file manager and appears as a 243MB and a 1862.78GB Healthy (Primary Partition) in Disk Management.*
I tried to boot into a Linux live USB and check the drive, it appears to have only 3 folders, boot, etc, and media. All empty. So then I tried teskdisk after searching on the internet and felt hope!
Indeed this thing is awesome, after running deeper search, I can see my original partitions. However, I do not know what to do from this point. I have included the log file, to make it easier, the original partitions I had were: Workstation, Media Center, Programs and New Volume. So please, help me recover my stuff! Those are of great importance to me and I will be very grateful if someone would assist me on this.
Again, thank you for viewing. :D