Page 1 of 1

[Solved] TestDisk partition write unsuccessful

Posted: 04 Feb 2014, 13:06
by indexOf
Hi,

Yesterday, I successfully recovered my 1To disk with TestDisk. I wrote back 2 partitions as L in TestDisk (I wasn't sure if I could write 2 partitions as P). The partitions were detected in Disk Management after a refresh.

(I can't remember if I rebooted or not, may be yes, as I followed the tutorial)

But, today the entire disk disappeared while still visible in Disk Management which asked me to initialize the disk to MBR or GPT. And, TestDisk couldn't find any partition, only read errors and CRC errors!

I suspect that the disk geometry is wrong, but how could it be possible? If that's the case could someone help me find the right values? And will initializing the disk kill my chance to recovery the partition table?

The sector size is 512 and for CHS:
Capture2.PNG
Capture2.PNG (9.52 KiB) Viewed 1601 times
Edit:
I ended up installing Intel rapid storage which told me that one of the RAID0 disk was not visible. It turns out that the problem was temporary, now the RAID0 is mounted successfully.

So it's just a silly coincidence between me deleting partitions by accident and some hardware failure...

Re: TestDisk partition write unsuccessful

Posted: 04 Feb 2014, 14:32
by Fiona
Currently your disk geometry looks ok.
Can you check your windows eventviewer / system and messages like disk?
Would it be possible that your motherboard has a hard disk controller problem?
Can you check your hard disk at another PC or put it into an USB enclosure?
Also test your disk using crystal disk info:
http://crystalmark.info/software/Crysta ... dex-e.html

Before you're going to modify anything to your disk, like initializing you should exclude anything wrong with memory management and read errors.

Fiona

Re: [Solved] TestDisk partition write unsuccessful

Posted: 04 Feb 2014, 14:38
by indexOf
Hi Fiona,

Thanks for the answer, I just updated the first post.