Page 1 of 1

Unrecognized boot partition, filesystem damaged

Posted: 09 Feb 2014, 06:37
by Warmonger
Looks like pretty severe case.

I have RAID 10 with 3 logical partitions and 100 MB Windows partition. Recently I replaced my old faulty disks so that now there are 2 ~500 GB disks and 2 ~1000 GB disks. It all worked fine for last three weeks. though system decided not to use one of 1000 GB disks (offline member), possibly for extended partition.

However, yesterday it all collapsed and RAID started to show as "failed". Following this guide, I dissasembled RAID, then rebuild it, hopefully with same settings.

Now, after deep search, TestDisk shows the following:

My system partition and (I assume) boot partition is gone. Deep search recognized 8 partitions in total (possibly 4 x 2), though I couldn't select complete partition set without getting"BAD". This is what I ended up with.
Filesystem for all partitions seems damaged.

Now, I probably would like to reinstall system and try to recover missing files with PhotoRec, though first of all partition structure should be rebuild. Any structure on how to proceed?

Re: Unrecognized boot partition, filesystem damaged

Posted: 11 Feb 2014, 07:09
by Warmonger
Still puzzled by this one.

I can give up most of data, but at least need to have disk working to reinstall system.
Going to post all the data about all partitions soon.

BTW, is it normal that "undelete" function freezes the computer? I left it overnight and it didn't respond :?

Re: Unrecognized boot partition, filesystem damaged

Posted: 13 Feb 2014, 07:21
by Warmonger
This is progress report:

In managed to get the disk working by setting Windows 100 MB partition to boot (*) and each of other 3 partitions to primary (P).

Then launched Windows Installer. Over 23 hours it probably managed to fix my 2nd partition (WORK), but failed to repair 3rd partition (DATA). That's okay for now.
The thing is, installer didn't suceed. It froze at "finishing installation". I left it overnigth and nothing changed, so I reset computer. However, now every time installer detects error and tries to restart system.

Once again I have "degraded" RAID 10 with first of the large disks showing as "offline member". That's just how it worked before it failed some days ago.

How can I stop this disk from getting "offline" every now and then?
And how do I finally install Windows? Probably need to format 1st partition, but that can be risky if not all the disks are online.

EDIT: Windows fails to configure on my setup. I did some search and probably it is caused by faulty remains of third partition. The thing is, I want to restore the data from that partition eventually.
Both MFT tables for 3rd partition are damaged. What to do to bring it back to work (even at the risk of loosing files?).

Re: Unrecognized boot partition, filesystem damaged

Posted: 13 Feb 2014, 11:22
by Warmonger
Formatting both DATA partition (which showed as empty in Windows Installer) and boot 100 MB partition didn't help.

What actually solved the issue was to install newest drivers (Intel Rapid Storage, in my case).

Now it's the time to recover my files.