Page 1 of 1

External drive; messed up partitions

Posted: 16 Feb 2014, 05:36
by Spongeworthy

My External 2 TB WD drive suddenly wasn't able to be recognized by my PC. So I figured it was the usb connection since it started malfunctioning if I even touched the cable. So I took it out of the enclosure, and connected it directly to my PC. It said the disk was uninitialized, I didn't want to initialize, or format the drive since there is data I need to retrieve from it. I've tried all sorts of partition recovery, data restoring programs, but they don't produce any results, or the files it gives me are all renamed and unusable. I tried repairing the MBR to see if it would make my drive usable again, but it split my drive up into multiple partitions(it was only one before). I tried using multiple partition recovery and file restoring programs but they produced no results. When I used testdisk's analyse function it gives me this :


Disk Management gives me this :


Using quick search doesn't give me any partitions, I'm currently doing Deep Search now. I hope I didn't screw anything up. Is there anything I can do?