Page 1 of 2

Analysis - PArtition: REad Error

Posted: 09 Mar 2014, 17:26
by monzarrate
I have been reading some posts trying to understand someone who had a similar problem.
The point is that I can see my external HD iOmega 500Gb in Windows, but when I try to open any folder it is not opening and Windows asks to "Format the HD".
I tried first chkdsk /f :g , but most of the files were not accesible.
Few days ago, I tried TestDisk and after anayze I could find a partition. But right now, opening from my Windows 7 as "Administrator", when I try Analyse, the message I receive is "Partition: Read Error".
Afterwards, I select "quick search", and it start analyzing the cilinders (but it takes hours and hours and still only 12% completed).
What could I do??
I have also selected at the beggining "Create" log, but I cannot find it in the same folder where TEstDisk is located.
Thanks in advance!

Re: Analysis - PArtition: REad Error

Posted: 10 Mar 2014, 14:20
by ninja
Generally the the file testdisk.log is in the main test disk directory.

Depending on the HD capacity (and errors) Test disk may take hours to search, even in quick search mode.
Quick search It took almost 2 days for me: WD 2Tb sigle partition.

Do you receive the "Read error XXX/YYY/ZZZ (lba NNNNNNN) ?
X = cylinder number;
Y = heard number;
Z = sector number;
N = lba number.

Re: Analysis - PArtition: REad Error

Posted: 10 Mar 2014, 23:05
by monzarrate
Hi Ninja,
Exactly, the lines you wrote and I have added at the bottom are what I can see all the time.
After 3 days I have stopped.. it was too slow and still it was in 25%. The HD is iOmega 500Gb.
"Read error XXX/YYY/ZZZ (lba NNNNNNN) ?
X = cylinder number;
Y = heard number;
Z = sector number;
N = lba number

I have plenty of photos from some trips that I would specially like to recover. Any help I would honestly appreciate very much!

Re: Analysis - PArtition: REad Error

Posted: 10 Mar 2014, 23:49
by ninja
my first suggestion is to create an image of your HD. Believe me, it is way more relaxed to experiment data recovery on a backup file.

It's very easy: you need a HD larger than 500GB. Read here:
It took me 6 hours on a WD 2 TB.

Generally read error are pending/damaged clusters, but can be fixed.
Quick/deeper search seems not to work on your HD. Try to repair the system file with Testdisk backup MBR

I've few question:
- What version of Windows are you currently using?
- Have you intialized the damaged HD?
- Have you already tryed with Photorec or other data rescue sw (e.g. Recuva) ?

Re: Analysis - PArtition: REad Error

Posted: 11 Mar 2014, 00:21
by monzarrate
My laptop has a Windows 7.
I have tried to read the HD from explorer. I can see the HD and the folders, but I cannot get inside the folders.
I tried photorec and it said that there were no partition, so I could not do much more.
Recuva I have not tried.

So, I will get anothe HD and create the image (I will get one on Wednesday).
Once the image is created, I will follow the link you send in your previous post.
Finally, in the damaged HD, I will try to repair the system file with Testdisk backup MBR.

I will let you know in 2 days! Thanks for your guidelines.

Re: Analysis - PArtition: REad Error

Posted: 12 Mar 2014, 22:21
by monzarrate
Hello ninja,
I have tried both options,
1. Create an image of the HD in Advanced menu, Image Creation. But testDisk says that there is "no Partition".
2. MBR code, Try to create - Write a new MBR code to first sector? Y - It returns same message. "No Partition"

I hope still there is a chance to recover some information.


Re: Analysis - PArtition: REad Error

Posted: 13 Mar 2014, 08:40
by ninja
Mount your *.dd image with OSForensic.
Then on the image drive try this sw: Magic partition recovery, Stellar Phenix data recovery.
If possible, back up your raw data.

If I were you, I will not touch again the physical HD. You may start to consider to have professional working on your data recovery.
Kroll Ontrack is one of the most famous. Online you can find cheaper firm.

Re: Analysis - PArtition: REad Error

Posted: 24 Aug 2014, 18:35
by gabinka0102
I think that the long duration of the quick search or deep searching was caused by choosing a wrong partition table type. It happened to me - Testdisk chose some table type and it took hours and hours. Then I chose manually Intel type and the quick search was done quickly. However there was no partition table found :( Maybe choosing another type could fix the problem?

Re: Analysis - PArtition: REad Error

Posted: 06 Nov 2014, 18:54
by Nick
Hi all, I've almost same problems with an external usb hard disk. The disk has several bad sectors and also partition table seems to be damaged, so I tryed to recreate it with testdisk. On first attempt it found all partitions, so I saved it by clicking on "write" but nothing happened, the hdd is still detected as unallocate space at disk management..
Now trying to make another quick scan and it freezes at 33% because of read errors..
How to do?

Re: Analysis - PArtition: REad Error

Posted: 07 Nov 2014, 08:24
by Fiona
@ nick

If you have bad sectors, you should consider to clone your disk sector by sector.
If testdisk displays your data you can try to copy/backup them to another healthy disk or partition.
If your file system is damaged you should use datarecovery software.
Bad sectors are not readable anymore.
It can cause that testdisk, your OS and datatrecovery software hang.
Please let me know, are you still able to list your data?

Run smartmon or crystaldiskinfo to check your disk.
If you'd like to use crystaldiskinfo, please download the portable version, because the installer (exe) contains adware Open Candy.
In case after datarecovery, replace your disk.