Page 1 of 1

EXT4 Recovery Question

Posted: 15 Nov 2014, 09:43
by drnuclear

I've got a Synology NAS DS213 that has RAID1 and 2 External Hard Disks attached via USB and a hard drive dock.

Everything is OKAY with the RAID1.

I'm having problems with one of the external hard disks attached via USB. It's a 2TB Seagate.

The Synology NAS doesn't recognize the drive anymore. I even tried accessing the Synology via SSH and did a df at the command line and the drive didn't show up.

So I started up testdisk and attached it to my MacBook.

Running testdisk, I see the directory structure and I am able to copy files. Thank god!

However, I'm not sure how I should go about repairing the drive. Is there something wrong with the partition? Do I need to run fsck.ext4 ?

I've never repaired a hard drive with EXT4. I have repaired hard drives formatted for Windows before and have had success.

I ran testdisk and one of the messages I got was this:

Warning: the current number of heads per cylinder is 1
but the correct value may be 64.
You can use the Geometry menu to change this value.
It's something to try if
- some partitions are not found by TestDisk
- or the partition table can not be written because partitions overlaps.

I'm not sure what the parameters are for a normal drive attached via USB. Should it be Primary or Extended or Logical ?

Worst case scenario I might just buy another hard drive and just copy all the data over...