Page 1 of 1

Two external HDDs gone RAW after USB unplugging

Posted: 02 Mar 2016, 23:40
by evejj

I know this is a common problem, but I'm confused by the different instructions I find so far. Maybe someone can help me figure out the next steps:

I have 2 external HDDs that are usually plugged to my PC (Win 10). Yesterday I had them connected to my Notebook (also Win 10) to copy some data and in the end I just unplugged the USBs without using the safe unplugging option :oops: (meh...). After replugging to my other PC both HDDs get registered as hard drive but show up as RAW and with different drive letters.

Both are 2,5 inch. One is 500GB, the other 1TB and both are just one partition and NTFS.

What I did so far:

I tried to follow some instructions I found for a recovery with the smaller HDD but ran into some errors:

In TestDisk the HDDs get default table type "None", which I changed to "Intel", since most instructions tell to do so. Also I wasn't sure if I should check the "Drive" oder the "Disk" that gets listed in TestDisk, so I tried both:

Doing a QuickSearch on the "Drive" gives me in the end --> "No partition found or selected"

Then I tried Analyze on the according "Disk":
1 Analyze
1 Analyze
small-1-analyse.png (16.61 KiB) Viewed 856 times
A Quick Search will not run but gives me the following error:
2 Quick Search
2 Quick Search
small-2-try-quick-search.png (21.09 KiB) Viewed 856 times
When I continue it shows the NTFS partition:
3 Continue after Quick Search
3 Continue after Quick Search
small-3-continue-after-quicksearch-error.png (21.29 KiB) Viewed 856 times
When trying to list files with P after that it just says "Can't open filesystem. Filesystem seems damaged."

I’m really not sure what to do now because of the above error. Should I do a “Deeper Search” now and then try to write the partition table?
Or is it more likely to be a problem with the boot sector and I should just do --> TestDisk – Advanced – Boot – RebuildBS ?
Or should I change the Geometry settings first because of the error ?! (I found a suggestion to do that in a similar thread)

I don’t want to damage anything but I’m totally confused what to do now. So I’d be glad if someone could give me advice what the next step in this scenario would be.
(For the sake of safety I currently use PhotoRec to copy everything it can find to another harddrive, but I'd rather have the filesystem back ;).)

Thanks a lot!

Re: Two external HDDs gone RAW after USB unplugging

Posted: 03 Mar 2016, 07:53
by cgrenier
Run "cmd" (right click run as administrator), "chkdsk /f d:" (replace d: by the correct drive letter)

Re: Two external HDDs gone RAW after USB unplugging

Posted: 03 Mar 2016, 13:51
by evejj
Thanks for your reply!
May I ask why you suggest doing chkdsk? I'm far from really understanding the matter but I read a lot of times, that one should not run a fix with chkdsk in such a case because it could do even more damage, especially if there is something wrong with the geometry (which the error message would suggest, i guess?!)

Isn't there another way I could try to fix it?
I had PhotoRec running during the night and it seems something is indeed wrong with the disk. It found some files but then it searched about 8 hours through a similar numbered range of empty sectors, so I quit that. There wasn't much free space on the disk...

Also a Deeper Search with TestDisk got me the same error message as above with the wrong number of heads per cylinder.

I also tried to just create an image of the disk to run further tests on that. I tried Macrium Reflect Free for that.
The bigger disk is recognied correctly there with 1TB space and most of it full with data. But the smaller disk is shown as empty and has odd values: disk size 465.76GB - data size 16777216.00 TB - free space 0B.

I'm not sure what this can mean. But I'd appreciate any help or suggestion what I can do now (except chkdsk ^^)