Page 1 of 1

fsck : more filesystems detected. This should not happen

Posted: 01 Jul 2016, 19:22
by arun
I accidentally formatted my USB drive which was formatted in ext4 to exfat using the command
mkfs.exfat /dev/sdb1

I was trying to recover it using testdisk. It was able to detect the filesystem, but couldn't read it and gives me a warning of damaged file system.

So tried using sudo fsck.ext4 /dev/sdb1, which will repair the damaged file system. But when tried to mount, I was getting the below error :

arun@lenovo-pc:~/Desktop/testdisk-7.0$ sudo mount /dev/sdb1 /media/usb2
mount: /dev/sdb1: more filesystems detected. This should not happen,
use -t <type> to explicitly specify the filesystem type or
use wipefs(8) to clean up the device.

I tried with sudo mount -t ext4 /dev/sdb1 /media/usb2 the it is able to mount properly and I was able to see the lost data.

But my question is why fsck can not properly repair the first sectors. Is there a way to properly repair the first sectors to properly rectify the damage done by mkfs.exfat command, so that I can mount directly with out any issues ?

Is there anyway to recover data from the superblocks using testdisk ?

Re: fsck : more filesystems detected. This should not happen

Posted: 02 Jul 2016, 08:20
by cgrenier
You can run the following command

Code: Select all

dd count=1 if=/dev/zero of=/dev/sdb1
Be VERY CAREFUL, you will wipe your data if "count=1" isn't used.