Page 1 of 1

GParted broke the partition

Posted: 09 Jul 2016, 18:23
by Ronson
I needed to resize a partition on a 40 GB HDD so I could clone it to a smaller space on another drive. I tried using some Windows based program but they wouldn't do it. I tried defragging the drive to open up space at the end of the partition but couldn't wait hours for it to finish. I tried using GParted in Fedora. It resized the partition but after I restarted my computer and booted to Windows 7 I found the partition or filesystem was lost or corrupted. Windows wanted me to reformat the drive. I started chkdsk on the drive but pressed Ctrl+C a few second later to stop it. In this case chkdsk probably will cause more problems than it will fix. Sorry, probably was a mistake to start chkdsk but I did it.

I started TestDisk 7.1 WIP and found two partitions that can't be recovered:
Capture3.PNG
Capture3.PNG (13.91 KiB) Viewed 1242 times
Then if offered the following three partitions:
Capture4.PNG
Capture4.PNG (16.01 KiB) Viewed 1242 times
which do I choose and why?

Re: GParted broke the partition

Posted: 09 Jul 2016, 19:34
by Ronson
If I go back to GParted and extend the partition back to the full disk, like it was, then would the two partitions in the first screenshot become recoverable?

Re: GParted broke the partition

Posted: 09 Jul 2016, 19:42
by Iceking007
Analyzing partitions and disks with TestDisk will never do any harm, it is only going to read data from all areas of the drive, unless you write to the drive (it will ask for confirmation).

I'm having a drive size and write error problem also, fiona is good with those as I've read on the forums but she has yet to reply to my post yet.

Good luck with your drive.

Re: GParted broke the partition

Posted: 09 Jul 2016, 20:16
by Ronson
I'm not worried about the message in the first screen shot about the drive possibly being too small. It really is a 40 GB HDD.

Re: GParted broke the partition

Posted: 10 Jul 2016, 05:15
by Ronson
I cloned the original drive and tried extending the partition of the clone to the full disk just to see what would happen. GParted wouldn't do it. It recognized there's a problem with the filesystem on the drive and wouldn't touch it. I tried undeleting the partition with the most sectors. That worked but I still can't use TestDisk to browse the files on the drive. TestDisk tells me the filesystem is corrupt.