Page 1 of 1

Lost partition/data - reed error message

Posted: 05 Jun 2012, 10:27
by artur
Dear all,

I hope I am not describing situation that is already available on forum.

During copying a data the external disk lost connection and from that time is not accessible under windows (communicate - disk is not formatted do you want to format it now?).

I have run analysis - under windows it was extremely slow ( 1%/1 hour).

Under linux was much better but:
when I run analysis first communicate is ----> Partition: Read error
quick search ---> Structure: Ok.
enter --------------> No partition found or selected for recovery
Deeper search ---->Structure: Ok.
enter --------------> No partition found or selected for recovery

log file is 1.4 GB large and contains line like:
file_pread(7,8,buffer,241537480(15035/3/17)) read err: Input/output error

What should I do to restore my data?

Is any hope?

with best regards


Re: Lost partition/data - reed error message

Posted: 07 Jun 2012, 14:21
by remy
Unfortunately it looks like your problem is hardware related. Under linux, did you try to check SMART ? Is your disk well recognised ? Are you able to uplicate it to another disqk using bit to bit tools like ddrescue ?

Re: Lost partition/data - reed error message

Posted: 30 Dec 2014, 17:29
by joseba
Good afternoon,

Recently I had the same problem with my backup external HD of 500 GB. I've trying TestDisk a lot but I arrived nowhere ... My Windows 7 PC has taken 5 or 6 days to analyse the HD and I have a 5GB testdisklog file.
In the screen after analysis I find this:

Disk /dev/sdb - 500 GB /465 GiB - CHS 60801 255 63

No partition available

What can I do ?, is there any solution?

Many many thanks for your soft, for your web and for your effort. Happy 2015 !!

Re: Lost partition/data - reed error message

Posted: 31 Dec 2014, 11:47
by joseba
More information about the problem I have.

After trying to Rebuild a BS I reached the screen I'm annexing.

I have to detail that when I started to have the problem, the PC was able to detect the disk (unit D:/), and I was able to reach most of the content of the disk, not all. But the PC did it very slowly, it was taking a lot of time to show the content of the unit. As I was not able to reach everything, AND I HAVE A SECOND BACKUP DISK (so my problem is not to recover the data inside, but to recover the HD itself to continue using it), I followed the windows suggest to format the HD. I never been able to format it from Windows, it seemed to be blocked in the format screen. I tried many times in different PCs (in a Windows XP and in a Windows 7), but I arrived nowhere.

Now the situation seems worse, as the PC continues to detect the unit once I connect it via USB, but it is unable to show the content and directly suggests to format it. And with TestDisk I obtain what I've explained.

Many thanks again for your work. Have a very good 2015 !!

Re: Lost partition/data - reed error message

Posted: 31 Dec 2014, 11:53
by joseba
One more question:

as I have a second backup HD, IDENTICAL TO THE ONE I'M INTO TROUBLE (both are Iomega 500GB, same model), can I copy any file system or so from the good disk to the bad disk in order to rebuild the bad one ?.