Page 1 of 1

Recover 2TB My Book on Mac

Posted: 09 Aug 2016, 16:48
by ewarren
Hello to all,
Here is my challenge. I had a 2TB WD "My Book" in an enclosure that would no longer power up. I did some research and carefully disassembled the enclosure and retrieved the hard drive. I inserted it in a Voyager Q dock and tried it on two different Macs. I received the error that "this disk is not readable by this computer"

I did some more research and end up downloading TestDisk and ran the "analyse" feature. It took two days to complete. When I got to the final stage I thought it had worked. It said something like "reboot to recover drive" I did and nothing happened. However I did close the terminal window before shutting down.Was I not supposed to do that?

I'm in the process of re-analysing on a second machine (needed to free up my laptop) So these are my questions.

Am I using the correct procedure? And after the analyzing completes what are the steps? I read the step by step instructions but it was still unclear to me as to what exactly I am supposed to do.

Thank You very much for any help.


Re: Recover 2TB My Book on Mac

Posted: 10 Aug 2016, 15:53
by cgrenier
Without the testdisk.log file content and its information, it's difficult to help you.
If the partition is missing, run testdisk, Analyse, Quick Search... as written in TestDisk Step by Step.
If the partition is present but the filesystem is damaged, I need to know the filesystem type.

Re: Recover 2TB My Book on Mac

Posted: 18 Aug 2016, 17:53
by ewarren
Ok the new scan has completed and here is the current window. This is where I messed up last time by really not knowing what to do next. How do I proceed.
warrengentry-testdisk_.jpg (52.53 KiB) Viewed 848 times

Re: Recover 2TB My Book on Mac

Posted: 21 Aug 2016, 19:05
by ewarren
Just looking for a little guidance on this issue. Thanks!