Page 1 of 1

Corrupted SD card : Partition sector doesn't have the endmark 0xAA55

Posted: 11 Jan 2017, 01:22
by Lorenzaccio
Hello everyone,

2 days ago my SD card was not recognized anymore by my smartphone. I tried to access it with ubuntu, but to no avail : no error message and nothing in nautilus.

I tried "ls -la /dev/sd*" with and without the card inserted to determine that my card was "/dev/sdb".

I tried to mount it using different options (vfat, msdos), none of which worked.

Before doing anything else, I backed-up the card.

Then I ran testdisk (quick search and deeper search), but no partition was found :

Code: Select all


Wed Jan 11 01:10:51 2017
Command line: TestDisk

TestDisk 7.1-WIP, Data Recovery Utility, August 2016
Christophe GRENIER <grenier@cgsecurity.org>
http://www.cgsecurity.org
OS: Linux, kernel 3.13.0-106-generic (#153-Ubuntu SMP Tue Dec 6 15:44:32 UTC 2016) x86_64
Compiler: GCC 4.4
ext2fs lib: 1.42.8, ntfs lib: libntfs-3g, reiserfs lib: 0.3.1-rc8, ewf lib: 20120504, curses lib: ncurses 5.7
/dev/sda: LBA, HPA, LBA48, DCO support
/dev/sda: size       781422768 sectors
/dev/sda: user_max   781422768 sectors
/dev/sda: native_max 781422768 sectors
/dev/sda: dco        781422768 sectors
Warning: can't get size for Disk /dev/mapper/control - 0 B - 0 sectors, sector size=512
Hard disk list
Disk /dev/sda - 400 GB / 372 GiB - CHS 48641 255 63, sector size=512 - TOSHIBA MK4055GSX, S/N:896KT4H4T, FW:FG011M
Disk /dev/sdb - 8061 MB / 7688 MiB - CHS 1024 248 62, sector size=512 - Generic- Multi-Card, FW:1.00

Partition table type defaults to Intel
Disk /dev/sdb - 8061 MB / 7688 MiB - Generic- Multi-Card
Partition table type: Intel

Analyse Disk /dev/sdb - 8061 MB / 7688 MiB - CHS 1024 248 62
Current partition structure:

Partition sector doesn't have the endmark 0xAA55

search_part()
Disk /dev/sdb - 8061 MB / 7688 MiB - CHS 1024 248 62

Results

interface_write()
 
No partition found or selected for recovery

search_part()
Disk /dev/sdb - 8061 MB / 7688 MiB - CHS 1024 248 62

Results

interface_write()
 
No partition found or selected for recovery
At this point, I was ready to format the card, but I wanted to recover my files, so I did a photorec with default options (and choosing Other for the filesystem type), but I recovered nothing, not a single file.

What else can I do to try to salvage at least some files ?

Re: Corrupted SD card : Partition sector doesn't have the endmark 0xAA55

Posted: 11 Jan 2017, 08:59
by cgrenier
Is the reported sd card capacity correct ? If it's wrong, the flash controller is probably damaged.

Run TestDisk, Advanced, Image Creation. Zip the image.dd file. What is the size of the archive ?
If it's very small (a few MB), the content of the card has been wiped, it may be an electronic problem.

Re: Corrupted SD card : Partition sector doesn't have the endmark 0xAA55

Posted: 13 Jan 2017, 00:05
by Lorenzaccio
The reported sd card capacity is correct.

I can't do the image creation with TestDisk, when I select Advanced, it says "No partition available". At this point the only choice given is to Quit.

However, I made an image file using the dd command and zipped it. Its size is 60 MB. Does it qualify as very small ?