Windows Storage Spaces Recovery

How to use TestDisk to recover lost partition
Forum rules
When asking for technical support:
- Search for posts on the same topic before posting a new question.
- Give clear, specific information in the title of your post.
- Include as many details as you can, MOST POSTS WILL GET ONLY ONE OR TWO ANSWERS.
- Post a follow up with a "Thank you" or "This worked!"
- When you learn something, use that knowledge to HELP ANOTHER USER LATER.
Before posting, please read
Posts: 1
Joined: 09 Jun 2017, 16:29

Windows Storage Spaces Recovery

#1 Post by kingofheartsx44 »


I've found myself in sort of a strange situation. I apologize in advance for the novel that follows ... my situation is rather complex. I have a set of 3TB hard disks using Windows Storage Spaces on Windows 10. They were originally created on Windows 8.1. The drives are 3 WD30EZRX and 3 WD30EZRZ drives. EZRX are 512e formatted, but I believe EZRZ may be 4Kn.

Everything was working fine through the migration from Windows 8.1 to Windows 10, and the drives have operated nicely for over a year. As of recently, the storage pool disappeared from Windows Disk Management and Storage Pool Management and has since been wreaking havoc. I believe when Windows 10 tried upgrading the storage pool to a newer version, it may have tried formatting the storage space with a different logical sector size and lost my partitions. At the very least, the partition table was lost.

Windows 10 doesn't see the drives at all, except in device manager. Some tools can identify that the drives are present, but I'm unable to do much with them. Reclaime File Recovery is the only software that has been able to recover my files. The problem is that I was using deduplication ported from Windows server. I can recover the entire list of files that were lost, but many have zeroed out data because of the deduplication, making the majority unreadable. Also, it doesn't give me the option to leave out deleted files, so I fear that the deduplication index would be invalid if a deleted version of an index file was recovered in place of an unaltered version. Reclaime Storage Space Recovery is able to identify the storage pool as well, and I can even save a VHDX image of the pool ... but Windows reads this as a RAW filesystem and doesn't acknowledge that there are any files present on the disk.

Windows 8 can read all of the drives and recognize that they are used in a Storage Spaces configuration, but is unable to recognize the Windows 10 format. I assume this is because Windows 10 doesn't support 512e.

R-Studio software reports that there are sector problems. After sending in to a professional recovery place, they tested the drives and said they were all fine and that the problem was purely logical. I believe this only further confirms that the issue is somehow sector size related.

I have made VHDX copies of all 6 drives at this point. I can't mount them on Windows 10; They all read as either uninitialized or invalid. I can mount them on Windows 8, but that's as far as I can get. Windows 8 is really the only reliable way I've been able to run testdisk.

Now, for my questions:

1. Does TestDisk currently or will TestDisk ever support Windows Storage Spaces?
2. Rather than attempting to fix the storage space pool as a whole, do you have any suggestions for how I can work on each drive individually so Windows 10 will read them again?
3. Does TestDisk recognize the difference between a native 4k formatted drive and a 512e?

The attachment is a preview of what TestDisk shows on all 6 drives.

I apologize again for the novel, but I've been working on this recovery since March. At the very least, I'm hoping to gain some ideas towards next steps. Thank you again for your time!
CaptureTestDisk.PNG (13.51 KiB) Viewed 1596 times

Sponsored links

Posts: 2
Joined: 06 Feb 2018, 17:17

Re: Windows Storage Spaces Recovery

#2 Post by drops77 »

Did you ever find a solution? i have a similar problem but a lot simpler.

I accidentally quick format the joint windows space drive.
I dont know if to disconnect do 1 drive by itself, or do the storage space. Let it run for 30 minutes on the storage space and recover only 8 photos.