Hoping to recover a partition I deleted, expanded the disk, then repartitioned. Topic is solved

How to use TestDisk to recover lost partition
Forum rules
When asking for technical support:
- Search for posts on the same topic before posting a new question.
- Give clear, specific information in the title of your post.
- Include as many details as you can, MOST POSTS WILL GET ONLY ONE OR TWO ANSWERS.
- Post a follow up with a "Thank you" or "This worked!"
- When you learn something, use that knowledge to HELP ANOTHER USER LATER.
Before posting, please read https://www.cgsecurity.org/testdisk.pdf
Locked
Message
Author
Fenrir
Posts: 1
Joined: 19 Mar 2018, 09:22

Hoping to recover a partition I deleted, expanded the disk, then repartitioned.  Topic is solved

#1 Post by Fenrir » 19 Mar 2018, 09:51

Hey, nevermind it all started working! Don't bother reading if you don't need to, just have a good day! I'm leaving this here as a success story / in case it helps anyone in the future.

I wanted to reclaim some unpartitioned space from a disk I had split into an Arch boot partition and drive, and a generic storage partition (not my windows drive). It had a 200 MB boot partition, 8GB of unallocated space, and then the rest of the drive as ~250GB of storage.

I deleted the unused 200MB partition, then tried to expand the storage drive, but windows asked me to convert it to a dynamic disk. I said yes, oops. I then repartitioned the entire drive, in an attempt to assign it a drive letter to check if my stuff was still there. oops again. I did NOT format the drive, and I have not used it since.

I've tried a few things in testdisk, namely the quick search and the deep search. I have successfully found the old partition, named "common". However I get the message:

Disk /dev/sdb - 250 GB / 232 GiB - CHS 30401 255 63
The harddisk (250 GB / 232 GiB) seems too small! (< 258 GB / 240 GiB)
Check the harddisk size: HD jumper settings, BIOS detection...
The following partition can't be recovered:
Partition Start End Size in sectors
> HPFS - NTFS 1069 244 8 31445 62 41 487979008 [Common]
NTFS, blocksize=4096, 249 GB / 232 GiB

Hey, Somehow it started working anyway! I can browse and am now copying my data. I merely hit continue after these searches, and pressed P with my fingers crossed when I saw the drive was still listed.

THANKS!

Sponsored links

Locked

Who is online

Users browsing this forum: Bing [Bot] and 4 guests