Testdisk Frozen

How to use TestDisk to recover lost partition
Forum rules
When asking for technical support:
- Search for posts on the same topic before posting a new question.
- Give clear, specific information in the title of your post.
- Include as many details as you can, MOST POSTS WILL GET ONLY ONE OR TWO ANSWERS.
- Post a follow up with a "Thank you" or "This worked!"
- When you learn something, use that knowledge to HELP ANOTHER USER LATER.
Before posting, please read https://www.cgsecurity.org/testdisk.pdf
Post Reply
Message
Author
Sudormrf
Posts: 1
Joined: 21 May 2018, 14:34

Testdisk Frozen

#1 Post by Sudormrf » 21 May 2018, 20:50

Hello,

My laptop (Lenovo ThinkPad T450s) has a Windows 8 partition and an Ubuntu partition. Yesterday, in the Ubuntu partition, I ran "sudo rm -rf /* instead of "sudo rm -rf ./*", so I lost everything, so am trying to use testdisk to recover what I can. I was able to run Quick Search, it found an NTFS partition (Image 1), and it was able to list the files, or at least the folders, in the root directory. I attempted to copy them all over to an external hard drive (image 2). The first time, I may have used the destination, since I thought it would be /dev/sdc like it says. It copied about 200000 successfully, but 300000 failed. I then thought that /media was the right place, but now testdisk is frozen at 0 ok, 298520 failed (Image 3). It's been over 18 hours now. I was wondering if I should force shutdown my computer and restart the process by copying smaller components at a time? Or if force shutting down would cause more data to be lost.

I have attached the following pictures (I dont have access to the .log file currently):

Image 1: partition found by quick search
Image 2: Results after running sudo fdisk -l. 1st device is the hard drive I am trying to recover, 2nd device is my USB that GParted is running off of, 3rd device is my external hard drive I am trying to copy my files over to. The 3rd drive is a harddrive from a Windows 10 computer which is why it has the partitions.
Image 3: Image of my screen currently, where testdisk is frozen.
Attachments
Image 2.jpeg
Image 2.jpeg (121.5 KiB) Viewed 103 times
Image 3.jpeg
Image 3.jpeg (118.86 KiB) Viewed 103 times
Image 1.jpeg
Image 1.jpeg (70.94 KiB) Viewed 103 times

Sponsored links

User avatar
cgrenier
Site Admin
Posts: 4293
Joined: 18 Feb 2012, 15:08
Location: Le Perreux Sur Marne, France
Contact:

Re: Testdisk Frozen

#2 Post by cgrenier » 22 May 2018, 05:56

Run "dmesg", it may output io error message and explain the problem.
If testdisk has been able to list the files, the files on the NTFS partition are probably not be deleted.

Post Reply

Who is online

Users browsing this forum: Google Adsense [Bot] and 3 guests