Page 1 of 1

Add partition ignores my sector input

Posted: 07 Jul 2012, 22:55
by raid5guy
Hi there,

I'm using a raid-5 fakeraid names which is found in Testdisk (6.14-wip on windows 7) as "Intel Raid 5 Volume". When I add a partition it asks me for the startsector, endsector and type. I want to add 4295174144 as startsector (which is perfectly in range of 1-11721072639) but after hitting enter he ignores my input and puts 206848 instead. Is this some kind of overflow?

Thanks a lot for any help or explanation :)

Re: Add partition ignores my sector input

Posted: 08 Jul 2012, 07:12
by Fiona
What software did you use to create your RAID?
If you use a RAID controller you'll not have a real software or fake RAID.
Start sector also determines the direction of rotation.
I have no idea about the condition of your current array.
Would it be possible to copy and paste the content of the testdisk.log from your diagnose?
Before you go to diagnose your RAID you'll need an intact array.
Don't partition or reformat it!


Re: Add partition ignores my sector input

Posted: 08 Jul 2012, 12:42
by raid5guy
Hello Fiona,

thanks a lot for your help! It is an Intel Storage Raid 5 Volume, handled onboard by my GA-Z68XP-UD3 motherboard. I put in four 2TB disks (Samsung Spinpoint F4 EcoGreen) which are all fine. The Array lost two of the four drives, sadly I had deleted the array and remade a new one with the same metadata (Name, Stripsize, and sequence of disks etc.)

When everything was still fine, there where three partitions on the Array, in this order:
1TB encrypted TC
1TB NTFS (unencrypted)
3.5TB encrypted TC

I made a TestDisk run using EFI/GPT and after two days running it found a lot of weird partitions, around ten or so, because he found signatures in the encrypted volumes. Since I know the exact sectors and where each partition starts and ends of my original setup, I added them through Testdisk. I was able to browse and add the second one with Testdisk easily. After that I added the first one two, I entered start & end sectors and wrote the partition table (ms data/unknown). (everything happened before my first post) I mounted the partition in truecrypt and it worked on the first try. Everything is in best condition. However when I wanted to add sectorinfo for the third partition it didn't let me. Thats where I'm standing now, two of three partitions are recovered without problems, but I can't enter the data for the third one. :/

Re: Add partition ignores my sector input

Posted: 08 Jul 2012, 14:53
by Fiona
Especially if you have problems about TC it might be advisable to get in touch with simpson474.
He supports TestCrypt on computerbase de.
I've seen that your address is hamburg.
That's why I assume it's worth a try.

TestDisk works Intel standard.
Encrypted drives are not standard anymore as long as they're not decrypted.
Might be possible thatTestCrypt finds the right values and your header?



Re: Add partition ignores my sector input

Posted: 08 Jul 2012, 15:11
by raid5guy
Thanks for the pointer, I'll do that. Since not the whole drive is encrypted but only a partition, it should not disturb TestDisk to edit the partition data. Can you tell me why it worked on the first partition but didn't on the last? Or do you know another tool/way to edit the GPT table to be able to add my third partition?