Accidentally partitioned my external for windows bootable

How to use TestDisk to recover lost partition
Forum rules
When asking for technical support:
- Search for posts on the same topic before posting a new question.
- Give clear, specific information in the title of your post.
- Include as many details as you can, MOST POSTS WILL GET ONLY ONE OR TWO ANSWERS.
- Post a follow up with a "Thank you" or "This worked!"
- When you learn something, use that knowledge to HELP ANOTHER USER LATER.
Before posting, please read
Posts: 1
Joined: 21 Dec 2018, 20:26

Accidentally partitioned my external for windows bootable

#1 Post by DrBadDoctorMD » 21 Dec 2018, 20:31

Currently running

HDD1: 500 gb (main)

HDD2: 500 gb (not sure what this is for)

SSD: 500 gb (brand new, wanted to make this bootable)

External HDD: 1 TB

So I did something really dumb and instead of using a USB key, I accidentally picked my external HDD into the bootable windows the Windows USB/DVD Download Tool.

I can see the partitions in disk management, where 32gb of it is now ESD-USB (windows bootable) and 899 gb is unallocated.

How do I get back the 899 gb?

I've tried using testdisk (ran for 2 days, and unfortunately, my C drive ran out of space). I have no idea where testdisk "placed" the recovered files, or if it even recovered it. It must have, as I had about 400 gb free in my C: drive and now it has 5gb free.


Also, going forward, I'd like to pretty much just do a clean install of windows on my SSD and then just utilize my HDD1 and HDD2 to keep programs on, so I should probably do a full wipe of both HDD.

Disk mgmt pic:

Sponsored links

User avatar
Site Admin
Posts: 5084
Joined: 18 Feb 2012, 15:08
Location: Le Perreux Sur Marne, France

Re: Accidentally partitioned my external for windows bootable

#2 Post by cgrenier » 22 Dec 2018, 11:56

Use TestDisk, not PhotoRec.
Run TestDisk, Analyse, Quick Search, Stop, If it didn't find your NTFS partition, choose Deeper Search.
Set the NTFS partition as P(rimary). On next screen, choose Write, confirm, Quit and restart your computer.