Permission denied - Creating a live USB (OS X)

How to use TestDisk to recover lost partition
Forum rules
When asking for technical support:
- Search for posts on the same topic before posting a new question.
- Give clear, specific information in the title of your post.
- Include as many details as you can, MOST POSTS WILL GET ONLY ONE OR TWO ANSWERS.
- Post a follow up with a "Thank you" or "This worked!"
- When you learn something, use that knowledge to HELP ANOTHER USER LATER.
Before posting, please read
Posts: 1
Joined: 08 Apr 2019, 07:53

Permission denied - Creating a live USB (OS X)

#1 Post by raoulduke37 »

I'm currently trying to create a live USB to recover files from my iMac that is no longer booting. I've searched through the forums but can't seem to find any posts that relate to the problem I am having.

I've tried to create the live USB on a 8GB MS-DOS (FAT32) USB as well as a 2TB removable HDD Mac OS Extended (Journaled), I've followed the instructions in Chapter 4, 4.4 and have downloaded the Fedora ISO file, however my ISO file is called Fedora-Workstation-Live-x86_64-29-1.2 while the instructions has the ISO file as Fedora-Live-Desktop, I don't know if that is causing my problem.

I follow the terminal instructions and it all works fine until the last step where I drag and drop the Fedora image file to terminal and then type the rest of the command, after pressing enter I get the response: dd /dev/rdisk2: Permission denied. I've received this error on both the USB and the removable HDD.

If anyone has any idea why this is happening? Are the USB/HDD I'm using the wrong format? Is the Fedora image file I'm using wrong? If so could someone provide me the link/details of where I can get the correct image file, the one I'm downloading at the moment is from the Other Downloads section on the right hand side the 64-bit 1.8GB Live Image.

Thanks in advance.

Sponsored links

User avatar
Site Admin
Posts: 5277
Joined: 18 Feb 2012, 15:08
Location: Le Perreux Sur Marne, France

Re: Permission denied - Creating a live USB (OS X)

#2 Post by cgrenier »

Your command need to start by "sudo", something like "sudo dd if=Fedora-Workstation-Live-x86_64-29-1.2.iso of=/dev/rdisk2".
No partition from rdisk2 must be mounted.