The TestDisk Tool Worked but What Did I Do?

How to use TestDisk to recover lost partition
Forum rules
When asking for technical support:
- Search for posts on the same topic before posting a new question.
- Give clear, specific information in the title of your post.
- Include as many details as you can, MOST POSTS WILL GET ONLY ONE OR TWO ANSWERS.
- Post a follow up with a "Thank you" or "This worked!"
- When you learn something, use that knowledge to HELP ANOTHER USER LATER.
Before posting, please read
Posts: 2
Joined: 29 May 2019, 16:04

The TestDisk Tool Worked but What Did I Do?

#1 Post by BigDaveFromJers »


First let me say that this tool (TestDisk) is excellent. Helped me recover data from a drive that had failed with bad blocks. Had some very important pictures, videos, documents, and music files and fortunately from what I can see, I have not lost any data :) Kudos to the engineer of this software and I will be supporting in full!

I'm just trying to understand what I did to get Windows to be able to see the drive again, Lol!

Here's what happened. I was copying a large amount of data from a usb drive to the drive that failed. After which I logged out of my Windows account and allowed another user to use the PC. When I logged back in later that day, the drive had disappeared from the explorer. When I went to the Drive Mgmt component, the drive was listed as unallocated and all of the partitions were gone. I knew initializing the disk would possibly erase the data so I set about researching on how to recover the drive without data loss.

After hours of research, I stumbled upon the TestDisk tool. I ran the program but really didn't understand what it was telling me so I did not attempt any actions as I had not saved the data from the disk and did not want to chance losing any data. I then ran WD drive tools and it came back with sector / block errors. I tried to run Chkdsk from a command prompt / Windows shell, but since Windows wouldn't see the drive properly I was unable to do so. I also tried a rescue disk using a Linux distro but was unsuccessful there as well.

So yesterday I backed up the data from the partitions using the TestDisk tool. As there was alot of data to save, this of course took a day to complete. Today after successfully saving the data, I set about seeing if I could use the tool to see if I could repair the MBR / MSFT (not sure which one was corrupted). First I downloaded Seagate's usb startup tool and did a short test of the drive. That of course failed after 10 percent due to the bad blocks / sectors on the drive. I then ran the short fix in Segate's tool and that seems to have repaired what ever damage that occurred to the block / sector on the drive.

Afterwards, I rebooted back to Windows and ran the Drive Mgmt component and the drive was still marked as unallocated and needed to be initialized. I ran TestDisk again and this time I set about having the tool rewrite the MBR. I rebooted the PC, went back to Drive Mgmt and the drive was still listed as unallocated with no partitions, but was online and did not require initialization as before. I went back to TestDisk again and this time marked the partitions I determined to be valid as Primary and had the program write this data to the MBR / MFT.

When I rebooted the PC, Windows was able to see the drive and the partitions again! I checked the data which I wrote to the drive right before the failure and it seems there was no corruption. I'm not sure if any data was lost but from what I can tell all of the data is intact. I've already set about replacing the drive (the new drive is on the way) as I don't trust the drive anymore. I'm just trying to understand what I did for future reference. I'm attaching the log from TestDisk for review.
(1.88 KiB) Downloaded 50 times
Thanks again for such a great tool for drive recovery! Well done ;)

Sponsored links

User avatar
Site Admin
Posts: 5318
Joined: 18 Feb 2012, 15:08
Location: Le Perreux Sur Marne, France

Re: The TestDisk Tool Worked but What Did I Do?

#2 Post by cgrenier »

Each HDD has about 100 spare sectors. Some of them have probably been used when you rewrote the MBR and/or the boot sector with TestDisk.
So Windows is now able to read successfully some system area and lists your files.
It's not a miracle solution, you really should replace this disk.

Posts: 2
Joined: 29 May 2019, 16:04

Re: The TestDisk Tool Worked but What Did I Do?

#3 Post by BigDaveFromJers »

Oh yeah. Replacing the drive today as there is still a small partition marked as unallocated on the bad drive. It looks like a system partition and probably is where the damage occurred.
At least I was able to save the data from the drive. Hopefully my story will help someone else having a similar problem.