Page 1 of 1

HDD NTFS file system switched to RAW. Partition is found but can not list files.

Posted: 23 Jun 2019, 05:40
by AI2049
My Windows 7 desktop crushed with a BSOD. After I tried to restart it, it failed to boot the OS. I tried several times to run the “Startup Repair” option from the Windows Recovery Environment (WinRE). According to the logs, sometimes all checks were completed successfully, sometimes it found some errors, but it never solved the problem, computer still could not boot the OS.

After that, I have noticed that WinRE has created a new partition on my system disk – “System Reserved” (originally there was only one partition on the disk) and changed the drive letter of the system partition (where the Windows folder resides) from “C:” to “F:”.

I ran Victoria on the HDD, it found one error on the disk (probably, from a long time ago), but overall the disk health was reported as “Good”, the SMART looked Ok. I still could use the disk, could read and write files to it, I saw no corruption of my files on the disk, but I could not boot the OS from it.

I decided to restore the disk manually. I deleted the “System Reserved” partition with diskpart. It turned into “Unallocated”. Then with the program “MiniTool Partition Wizard Home Edition” I extended the system partition so that it would occupy the entire disk. Now the system disk was detected correctly as drive “C:”. I could read all my files from it, could launch programs from it.

Then I deleted the folder “boot” from the root directory, I reset BIOS, and re-seated memory modules and cables inside the computer case. I booted WinRE from a Windows 7 installation disk, and I ran the following commands in the Command prompt:

>bootrec /fixmbr
>bootrec /fixboot
Element not found.
>bootrec /rebuildBCD
Could not find any Windows installations.
The boot configuration data store could not be opened.
>sfc /scannow /offbootdir=C:\ /offwindir=C:\windows
Windows Resource Protection found corrupt files but was unable to fix some of them.

After that I checked the contents of the log file "C:\windows\Logs\CBS\CBS.log"
It contained no records of the date when I ran sfc. All the records in the log were of prior dates.

Then I turned the computer off and since that time the file system on my system HDD disk has changed to RAW. I can not see any files on the disk anymore, I can not run chkdsk on the disk, I can not mount the disk under Linux. The disk status is still reported as “Healthy (Active)”.

I tried to restore the disk with the TestDisk program.

“Analyze” right away has found one primary bootable partition with NTFS file system, spanning the entire disk, with an invalid boot sector.

Subsequent “Quick Search” has found no partitions at all.

Then “Deeper Search” again has found the NTFS partition, but the size was smaller, it started not at 0 cylinder, but at #13, and there was a warning: “The current number of heads per cylinder is 240 but the correct value may be 255”. After I tried to “list files”, it gave me an error message: “Can’t open filesystem. Filesystem seems damaged”.

HDD’s SMART status is still “good” as reported by Victoria.

This is the complete TestDisk log:

What do I do now? Should I try to change the geometry and try the search again?

Re: HDD NTFS file system switched to RAW. Partition is found but can not list files.

Posted: 26 Jun 2019, 06:29
by cgrenier
Can you retry with latest 7.1-WIP ?
The partition table type is PC Intel or EFI GPT.