0kb files recovery

How to use TestDisk to recover lost partition
Forum rules
When asking for technical support:
- Search for posts on the same topic before posting a new question.
- Give clear, specific information in the title of your post.
- Include as many details as you can, MOST POSTS WILL GET ONLY ONE OR TWO ANSWERS.
- Post a follow up with a "Thank you" or "This worked!"
- When you learn something, use that knowledge to HELP ANOTHER USER LATER.
Before posting, please read https://www.cgsecurity.org/testdisk.pdf
Post Reply
Posts: 1
Joined: 11 Dec 2019, 11:03

0kb files recovery

#1 Post by puqeyibe »

I have a 3TB WD Passport Drive. Yesterday I plugged it in and Disk Management showed it as unallocated. So I ran testdisk to rebuild the BS. It did.
But the weird thing was that the drive still showed as unallocated. Then I ran chkdsk /f on it. All of my files and folders appear, but probably 50% of them show as 0KB.
But now, Disk Management shows one partition of 2048GB and another at 1677.99GB that is unallocated. My drive initially had about 800GB left of free space.
Is there anything I can do to get these files back? Thanks a lot ;)

Sponsored links

User avatar
Site Admin
Posts: 5241
Joined: 18 Feb 2012, 15:08
Location: Le Perreux Sur Marne, France

Re: 0kb files recovery

#2 Post by cgrenier »

For partition bigger than 2 TB, your disk need an EFI GPT partition table (or 4096-bytes sector).
Honestly I don't know how to help you as it can be a problem of wrong disk capacity, wrong partition table, corrupted filesystem...
It's always possible to use PhotoRec to recover your data, at least it's safe as long as your wrote the recovered files on another disk.

Post Reply