Linux partition can't be recovered. Any options?

How to use TestDisk to recover lost partition
Forum rules
When asking for technical support:
- Search for posts on the same topic before posting a new question.
- Give clear, specific information in the title of your post.
- Include as many details as you can, MOST POSTS WILL GET ONLY ONE OR TWO ANSWERS.
- Post a follow up with a "Thank you" or "This worked!"
- When you learn something, use that knowledge to HELP ANOTHER USER LATER.
Before posting, please read https://www.cgsecurity.org/testdisk.pdf
Post Reply
Message
Author
avilqu
Posts: 2
Joined: 06 Feb 2020, 08:42

Linux partition can't be recovered. Any options?

#1 Post by avilqu »

Hi all,

I used testdisk on my laptop (XPS 9360 dual boot Windows10 / Archlinux) after Windows10 deleted the entry for my linux partition on the partition table. Testdisk does indeed find a linux partition, but tells me it can't be recovered, not sure why.

See my testdisk log here.

I've tried inputting the start and end sectors in parted rescue but with no luck. Do I have any other option? What about using gdisk to recreate the partition at the same sectors without formatting it?

Thanks for your help.

Sponsored links

User avatar
cgrenier
Site Admin
Posts: 5127
Joined: 18 Feb 2012, 15:08
Location: Le Perreux Sur Marne, France
Contact:

Re: Linux partition can't be recovered. Any options?

#2 Post by cgrenier »

After Quick Search, use 'a' to manually add the missing partitions. Use the arrow keys to switch the partitions from the list to P(rimary). The partition not listed from this list must be marked as D(eleted).
Use 't' to change the partition type if necessary.
On next screen, you can have:
1 P EFI System 2048 1026047 1024000 [EFI system partition]
2 P MS Reserved 1026048 1288191 262144 [Microsoft reserved partition]
3 P MS Data 1288192 368368407 367080216 [Basic data partition] [OS]
4 P Windows Recovery Env 401928192 403150847 1222656
5 P Linux filesys. data 403152894 1000215173 597062280
If it's OK (and only in this case), choose Write, confirm, Quit

avilqu
Posts: 2
Joined: 06 Feb 2020, 08:42

Re: Linux partition can't be recovered. Any options?

#3 Post by avilqu »

Thanks for the quick answer, and the amazing work done on testdisk.

After the quick search, I'm greeted with a table that seems a bit chaotic, with sector numbers all over the place. None of the partitions seem to be overlapping, but definitely there are gaps between the partitions. On the screenshot, you'll see a structure with Primary partitions that seems to work and does include the Linux filesystem, but given the complexity of the rest of the table I'm not quite sure it's safe to write. Any advice?

Thanks.

Post Reply