Page 1 of 1

Hitachi hard drive MBR specific problem

Posted: 16 Jan 2013, 22:21
by Azazel
I have upragraded the hard drive in my HP dv6000. Unforunately, XP is reporting that no hard drive is found and 7 that It can't install on HDD. I tried Ubuntu too, but the same error occured. In my Toshiba a200-satellite HDD works great without any problems.

In HP it reports a wrong MGR table.

I've been looking for drivers for HDD, but I found nothing, so I do't know if it requires some extra formatting or something, I don't want to screw something up.

I'm trying to solve this so long time :cry:

I really appreciate your help.

Re: Hitachi hard drive MBR specific problem

Posted: 17 Jan 2013, 16:41
by Azazel
I tried to do something on my own.

I run Testdisk on Toshiba, selected PC/Intel type,

Then I tried to repair MFT. Unsuccessfully.

I tried to write new MBR table,

And after reboot this occured.

Then I swap to HP and booted W7. I clicked the notice
05, 06

I continued I clicked to Create new space and the error has showed

So I opened console and typed CHKDSK.

I get the HDD shortly back to Toshiba where I created partition in W7 setup.

I swapped back, no changes.

Again tried to create new space but error popped up again.