Page 1 of 1

OS X HFS Repair still not booting

Posted: 13 Jan 2014, 22:09
by escarra
I have installed testdisk on my ubuntu machine to repair my Macbook Pro drive. The drive is an internally installed 256gb SSD with Mavericks, a second internal drive is installed and is used to run Windows 7. My system suddenly crashed in OS X and no longer boots into OS X.

What I have done:

- Removed drive from mac
- plugged drive into a sata to usb adapter then onto my ubuntu machine (12.04lts)
- I installed testdisk on the ubuntu machine and ran the program.
- I wrote the partition information and rebooted then
- I wrote the backup superblock to the hsf partitions which afterward reported they were now identical.
- reinstalled the drive into my macbook pro
- boot into windows selected boot camp my drive is not listed as available, also my drive still does not show up in windows explorer.

When I attached the drive onto my ubuntu machine the drive mounted and I was able to navigate to different folder and the like.

So I am at a loss as to what I do next, or did I miss a step?

Any help or advice that can be bestowed on me concerning my situation will be greatly appreciated. Thank you all in advance for any help.


Re: OS X HFS Repair still not booting

Posted: 24 Jun 2014, 18:04
by pevans
Just joined and browsing the wiki. Noticing that many entries have no response (?) So very quickly: I think you're quite lucky, at least you have your files! So you just need to restore them to their partition. If you install hfsutils on your linux box, you should be able to write to the disk that was in your Mac. Or, worst case, start the Mac with a recovery disk (eg SD card), get a Terminal window, and use scp to copy the files over the network.

I'm sorry this isn't step by step, I'm working on an unpleasant problem of my own at the moment...