Page 1 of 1

2x128GB SSD, Raid, Filesystem seems damaged

Posted: 29 May 2015, 01:30
by hklyn
Hi guys,

First, I have attached many photos of the process using TestDisk so far. As you can see, I have 2 SSD-disks, which TestDisk recognizes and is able to scan through. To me, it seems like it finds the two disks' contents, but that the filesystem is damaged. As such, using P to list files only gives the "Filesystem seems damaged".

So, my competence stops here. I've been working on this for several days and nights, as there are a lot of photos and documents I really just cannot lose. I've given up on trying to repair everything, I just need the files, and then I'll do a full format and reinstallation of Windows 8.1.

I have no clue why I couldn't boot all of a sudden and what might cause all of this. First, it seemed like the partition with the OS were unallocated suddenly, but I've messed around with TestDisk (pushed "write" too many times probably, tried to rebuild and so on, hoping to make Win 8.1 bootable again....), and now it seems like the partitions are there, but that I cannot access the files. Some hours ago, I actually could list the files, but trying to fix everything I wrote some new partition tables, tried to rebuild and everything, and after rebooting, I could no longer list the files.

What can I do? Any advice or help is greatly appreciated. I'm so desperate I'm considering sending the computer to some data recovery experts, but I'm afraid that will cost more than I can afford.

Please don't hesitate to ask me for more screenshots or information. As said, I've spent days on this and I won't move away from the computer before I've fixed this...

Re: 2x128GB SSD, Raid, Filesystem seems damaged

Posted: 29 May 2015, 11:02
by Fiona
The status of your RAID is failed.
Can you recreate your array exactly like before, without initializing, partition and formatting it?


Re: 2x128GB SSD, Raid, Filesystem seems damaged

Posted: 29 May 2015, 19:08
by hklyn
Hi, and thank you for your reply.

I'm afraid I'm not able to do that. While working with TestDisk, and it listing my files successfully, I was happy and thought it was just to write the partition table, rebuild, and reboot and voila (and I forgot to backup while doing this)..

Is there any way I could recreate how it was?

I'm attaching a picture that shows how it looks like now, and how sda and sdb look after a deep scan.

Re: 2x128GB SSD, Raid, Filesystem seems damaged

Posted: 29 May 2015, 19:11
by hklyn
By the way, here is how it looked like before I messed things up (when I was able to list all files successfully):

Additionally, MFT and MFT mirror are both bad..

Re: 2x128GB SSD, Raid, Filesystem seems damaged

Posted: 30 May 2015, 19:57
by hklyn
Ok, I'm getting desperate, so I'm trying out different data recovery tools. Have a hard time finding something good for NTFS and RAID that is bootable. Anyway, I tried MiniTool, which found a lot, but it found numerous partitions with different sizes (I only have 3; 2 normal and 1 recovery), and most files are RAW or "Lost", and the few that are not are corrupted (can't recognize a single jpeg). Additionally, of course, folder structure is not there.

So, at this point I have two questions:

1. Is it possible to recreate the array with TestDisk somehow? Is there any chance I can get everything back to how it was and make the computer bootable with all files and structures intact?

2. If not, what is the best data recovery tool given my hardware and situation? That is, which software is most likely to find the original partition structure and keep most files (and even folders...)?

Thank you so much for any help.