Drive was not partitioned but now has 3?!

Using TestDisk to repair the filesystem
Forum rules
When asking for technical support:
- Search for posts on the same topic before posting a new question.
- Give clear, specific information in the title of your post.
- Include as many details as you can, MOST POSTS WILL GET ONLY ONE OR TWO ANSWERS.
- Post a follow up with a "Thank you" or "This worked!"
- When you learn something, use that knowledge to HELP ANOTHER USER LATER.
Before posting, please read
Posts: 6
Joined: 30 Jan 2016, 21:46

Drive was not partitioned but now has 3?!

#1 Post by Lomax21 » 31 Jan 2016, 14:19

So this is very strange. I have a 3TB external seagate drive that the USB3 dock thing flaked out and the drive was starting and stopping before finishing it routine.

I swapped cases and the issue was the same thing. Windows sees the drive but wants it formatted. Disk management also sees the drive and claims there are now 2 new partitions, 3 in total. One is RAW the other 2 are just Unallocated.

I ran Testdisk and did the quick search and it came back saying it found an invalid FAT32 partition info, so I did the deep scan and about 6-7 hours later it found all 3 partitions and seems to say two are FAT and one is NTFS.

I've been through all kinda HDD problems from just losing the FAT tables all together to corrupted MBR/MFU's etc, but I've never seen something quite like this.

I guess the real question is should I just delete the partitions and try to rebuild? There is about 2TB of info I need to get back, some is backed up some not so I'd like to get as much back as i can.
This was the finale output of the deeper scan
Capture.PNG (15.31 KiB) Viewed 1065 times

Sponsored links

Posts: 6
Joined: 30 Jan 2016, 21:46

Re: Drive was not partitioned but now has 3?!

#2 Post by Lomax21 » 04 Feb 2016, 16:41

Any insight on this guys? I'm pretty sure I'm gonna need to go grab another drive to attempt to move the stuff off, but are the file names gonna be messed up with the file tables all screwed up?

Posts: 7
Joined: 14 Feb 2016, 06:47

Re: Drive was not partitioned but now has 3?!

#3 Post by oldefoxx » 14 Feb 2016, 09:26

You have stumbled on LVM, a new disk management hatched up to create logical partitons that can be scaled up and down to fit a need. I originallu expected it was from MS, but no, it's a new idea for Linux. It eats up a bit of drive space, which some don't mind, but I prefer ext4 which I control. If you want ext4 or any other type, you can get it via gparted or in the LiveCD process, take the last option and set up the partitions for yourself. Or reuse the existing ones if you have done this before.

gparted gives you the ability to label it as well and assign a UUID of choice, whereas the install process sails pass that. gparted will let you make changes later, and running sudo update-grub will being the boot process up to date. Only run sudo grup-install /dev/sda from the partition you want the boot process to boot to by default if you do not make a different selection. If you look into it further, you can even boot to and install from a LiveCD image stored on one of your partitions or drives. Handy if you decide to make some USB drives able to run Linux later, ot if you don't have a CD/DVD burner.

IfiLinux installs is not your game , you can get 16GB Thumbdrives on ebay with the latest Linux release on it for about $15. The drive is worth about $5, so you are paying $10 for expertise and labor. The software itself is free.


Who is online

Users browsing this forum: No registered users and 4 guests