Page 1 of 1

Can TestDisk Reformat?

Posted: 28 May 2012, 17:44
by SteveB
So, the good news is I was able to fully recover 100% of my corrupt data on my 1TB drive using testdisk to copy data.Thank you!

Once I recovered what I needed, I used MAC DiskUtil to try to erase the drive. The erase got about 40% done then DiskUtil gives me the following error:

"Disk Erase failed with the error: POSIX reports: the operation couldn't be completed. Cannot allocate memory."

Testdisk now sees the drive as a Mac partition, where before it saw it as an Intel/PC partition (it was a FAT32 drive).

I tried to initialize the drive using Drive Genius and received and "Initialization Failed" error.
TechTools Pro 5 sees the drive, but does not allow it to be selected in any of the diagnostic menus.

Can I use Testdisk to reformat the drive? It's the only app that sees it properly.

I could not find proper instruction on the wiki in this regard.

Re: Can TestDisk Reformat?

Posted: 29 May 2012, 09:07
by Fiona
Only operating systems formatting disks (adding a filesystem and boot sector/superblock/volume header to a partition).
Do you have an external disk?

If your file system was damaged, you should diagnose it first using the diagnose tool from the manufacturer.


Re: Can TestDisk Reformat?

Posted: 29 May 2012, 16:10
by SteveB
Thank you Fiona.

Yes, this is an EXT 1TB drive.

After I recovered the data with Testdisk, I attempted to format the drive with Disk Utilites in OSX. The process was partially completed, then failed with the error noted above.

I then tried Drive Genius and it failed to initialize the drive also. Techtools did not recognize the drive beyond indicated and ext drive was connected.

I then moved to terminal and tried to run Fdisk procedures shown in the attachment.

Test disk analysis shows the drive contains no partitions, so there is not much to work on.

Perhaps I need to look at another command line formating tool? Any suggestions?

Re: Can TestDisk Reformat?

Posted: 29 May 2012, 19:42
by Fiona
I already got pretty much cases where it was not possible to reformat an external disk.
An USB-HUB with power supply or plug that disk internally helped.
An USB-Y-cable didn't help as much either.
Some similar infos; ... pply#p2258


Re: Can TestDisk Reformat?

Posted: 29 May 2012, 20:37
by SteveB

I am able to mount this drive on a PC and format as NTFS. This newly formatted drive will mount on my mac as a generic empty drive.

However, when I try to format as HFS+ with disktutil or GUI app, the format fails, and the procedure renders the drive unreadable to the mac again.

But, I can now go back into test disk. This is what I get:
  • Testdisk sees the drive at /dev/rdisk1 (1000GB)
  • Testdisk sees the partition table as [EFI GPT]
  • Analysis produces the following errors:
    "Warning: Incorrect number of heads/cylinder 255 (NTFS) != 1 (HD)
    "Warning: Incorrect number of sectors per track 63 (NTFS) != 1 (HD)
    (see below for screen caps)
    /P on EFI presents another error: No file found, file system may be damaged.

At this point, I'm not sure how to proceed. :?:
1.png (79.29 KiB) Viewed 10538 times
2.png (80.4 KiB) Viewed 10538 times
3.png (39.56 KiB) Viewed 10538 times

Re: Can TestDisk Reformat?

Posted: 29 May 2012, 20:38
by SteveB
Lastly Files on the EFI partition:
4.png (57.92 KiB) Viewed 10538 times