Need help with a damaged drive

Using TestDisk to repair the filesystem
Forum rules
When asking for technical support:
- Search for posts on the same topic before posting a new question.
- Give clear, specific information in the title of your post.
- Include as many details as you can, MOST POSTS WILL GET ONLY ONE OR TWO ANSWERS.
- Post a follow up with a "Thank you" or "This worked!"
- When you learn something, use that knowledge to HELP ANOTHER USER LATER.
Before posting, please read
Posts: 1
Joined: 27 May 2016, 12:32

Need help with a damaged drive

#1 Post by maxsimonse »

Hi guys,

Three days ago, my external WD Elements 1TB disappeared all of a sudden from my Mac. It wasn't available in Finder, not in Disk Utility and it was not displayed on my desktop like it was before. After reconnecting didn't work, I started to worry. I decided to connect the drive to a different machine (Windows) to see if that recognized it. Unfortunately, it didn't show up in Explorer, but I was able to safely remove it via the menu in the lower right corner. In Disk Management, my external drive was labeled as 'Unallocated' and a pop-up appeared asking me to initialize the drive as GUID or MBR. I didn't do that, because I knew that it would destroy all data on the drive.

Back to Mac, it took quite a while after reconnecting it until it appeared in Disk Utility. Unfortunately, it was not showing the partition with all my files, just the name of the drive. After analyzing the drive in Testdisk, the partition with all my files seems to be OK. It said 'HFS+ OK' and "Sectors are identical". The EFI-partition on the drive (which I think is causing the trouble) was 'Bad', but the sectors were identical.

I've been trying to Rebuild BS, change the types and 'Write' partition tables, but nothing seems to work. When I try to repair, verify or restore the drive in Terminal (via GPT command line and DD) I'll get an 'Input/Output Error'. I also tried recovering the drive via Data Rescue, but that takes millions of years to complete and it warned me with a 'Slow Read Access' warning.

I'm frustrated, out of options and sad. Is there any way to recover all my data from this drive? There is no need for the drive to be functioning probably as I already bought a new one, but I really really need my files from this drive.

Any help would be very much appreciated! Thanks! :)

Sponsored links