Page 1 of 1

RAW Filesystem - not sure what to do.

Posted: 04 Jun 2012, 16:19
by Willem

Lately my dad's computer crashed and I figured there was a problem with the HDD, which is the case. I took it out and connected it to my laptop trough USB, but it did not show up and windows said it needed to be formatted. It does show up in BIOS.

I try to use TestDisk to recover these files. I got it to work once but when I start up TestDisk now, with my HDD connected, it says "Please Wait", it is doing it for 10 minutes now. It didn't take that long the first time.

The drive is visible in the Device Manager and BIOS but is not visible in explorer. Also, when I plug it in, one recovery partition shows up but the other two are still broken. One holds Vista and the other holds 7.

I would also like to add that I tried to use Acronis. That also didn't work out as it tried to load endlessly just like TestDisk does. But when I unplug my drive it shows up for 0.25 second or so and then vanishes again. It appears in TestDisk when I remove the disk, but when I then plug it back in and click next it says there are no partitions. In almost every program I try it tries to load the HDD endlessly until I disconnect it.

Any possible solutions or help? I really don't know what to do. Ask questions if needed, I will try to answer them as best as possible


Re: RAW Filesystem - not sure what to do.

Posted: 07 Jun 2012, 14:17
by remy
Try to duplicate first with ddrescue under gnu/linux, and then work on the copy.