GPT to MBR switch error

Using TestDisk to repair the filesystem
Forum rules
When asking for technical support:
- Search for posts on the same topic before posting a new question.
- Give clear, specific information in the title of your post.
- Include as many details as you can, MOST POSTS WILL GET ONLY ONE OR TWO ANSWERS.
- Post a follow up with a "Thank you" or "This worked!"
- When you learn something, use that knowledge to HELP ANOTHER USER LATER.
Before posting, please read
Post Reply
Posts: 1
Joined: 30 Apr 2018, 16:52

GPT to MBR switch error

#1 Post by richloomis » 30 Apr 2018, 17:05

I purchased a bare bones, stand-alone WD hard drive from Amazon, and used it with a "universal" style edge connector USB dongle and had the HD sitting on a shelf during use. Worked fine for more than a year, but "something" weird happened (perhaps via assigning a new drive letter, am not sure) such that the next time I tried to access it, no success. Shows as not initialized and no drive letter in Disk Management. Right clicking on drive within Disk Management does NOT bring up an option for assigning a drive letter. Instead a small box shows only four items available: Initialize Disk (grayed out), Offline, Properties, Help. Right clicking on the black single partition area brings up seven options (the first five are grayed out): New Simple Volume, New Spanned Volume, New Striped Volume, New Mirrored Volume, New Raid-5 Volume, Properties, Help.

Using CMD with administrator privileges so as to use the diskpart process does not work. Neither "list disk" nor "list volume" shows the plugged-in disk, only shows the SSD integral boot disk. Third party software does show the disk, but the only option is to perform a VERY long "repair" process for which I would first have to purchase another high capacity disk to transfer the data onto etc. So my hope is that the hardware/software problem can be fixed without doing all that.

I posted this problem at forums and got some help . . apparently some sort of glitch (or someone messing with my computer remotely?) caused the drive to somehow re-configure from GPT to MBR . . a fellow there had me try the TestDisk program, and I followed his suggestions as best as I could understand them, and posted screenshots of the results on the following forum link (I'm not sure if it will come up but beats trying to repeat every detail all over again): ... ve-letter/

Any ideas? Thanks

Sponsored links

User avatar
Site Admin
Posts: 4232
Joined: 18 Feb 2012, 15:08
Location: Le Perreux Sur Marne, France

Re: GPT to MBR switch error

#2 Post by cgrenier » 04 May 2018, 05:52

As testdisk has been able to find your partition and been able to list your files, you should write the new EFI GPT partition table with your NTFS partition.
The warning about the sector size isn't a real problem as long as you can see your files.

Post Reply

Who is online

Users browsing this forum: Google [Bot] and 2 guests