Page 1 of 1

Tricky one... Repairing software RAID 0+1?

Posted: 02 May 2018, 09:41
by revgrectifier
Hi everyone, I downloaded TestDisk as the people from Reclaimed recommended it to me, as a way to fix the partition table on my RAID.

My issue is as follows:
I have a 4-bay enclosure of four 2TB disks, and
- I put drive 1 and drive 2 in RAID 0, resulting in a fast 4TB drive;
- drive 3 and drive 4 in RAID 0, resulting in another fast 4tb drive.
- Those two 4TB drives are then in software RAID 1. I believe this is called RAID 0+1.
- All was done in MacOS Disk Utility.

The problem emerged when the enclosure when turned on wouldn't appear on my computer, and said the disk wasn't readable. I think this is due to a mistake I made when I turned the enclosure off while it was still working. All the drives are healthy, though.

When I try to repair the filesystem from terminal like described in test disk.pdf, I can do that only on single 2TB drives.

Repairing the filesystem/fixing the partition table seem the simplest way, but eventually it's ok also to recover the files directly, even with bruteforce.

I hope you can help me!

Re: Tricky one... Repairing software RAID 0+1?

Posted: 03 May 2018, 06:14
by cgrenier
A device for the Raid 0+1 should be visible, see ... s-x-10-11/
You should be able to use PhotoRec at least on this raid device to recover your data.

Re: Tricky one... Repairing software RAID 0+1?

Posted: 03 May 2018, 08:59
by revgrectifier
It is visible, but I tried PhotoRec and there is no way I can extract the files to another hard drive. The 4TB was almost full, and PhotoRec extracts files only on the disk it booted from, which is only 500GB.
Do you think it's possible to fix the situation in TestDisk? I haven't tried yet because I'm afraid it will write on the RAID, making file recovery more difficult later.
Is it safe to proceed, even creating a log file?

Re: Tricky one... Repairing software RAID 0+1?

Posted: 07 May 2018, 05:51
by cgrenier
You can choose the destination directory when using PhotoRec, you only have to mount the destination before starting PhotoRec.
Do not choose a destination on the source disk/raid.