damaged WD5000 ext HDD Topic is solved

Using TestDisk to repair the filesystem
Forum rules
When asking for technical support:
- Search for posts on the same topic before posting a new question.
- Give clear, specific information in the title of your post.
- Include as many details as you can, MOST POSTS WILL GET ONLY ONE OR TWO ANSWERS.
- Post a follow up with a "Thank you" or "This worked!"
- When you learn something, use that knowledge to HELP ANOTHER USER LATER.
Before posting, please read https://www.cgsecurity.org/testdisk.pdf
Posts: 2
Joined: 20 May 2018, 03:54
Location: australia

damaged WD5000 ext HDD

#1 Post by Mike1949 » 20 May 2018, 05:20

Hi all, new to CGS and forums. Long story, have been at this on and off for a while now. -in retrospect..big mistake... i exchanged manually the 1 Tb HDD of my WD for a 500G one, put the 1tb into a security DVDR. didnt do anything special, just undid casings, handled carefully, exchanged ,plug-n-play. ever since have had problem, cant access the HDD in the WD box. DVDR seem fine!. am running from a USB. have checked the USB's and cabling. win wont recognise the HDD fully, even though i can get it to show in devices as functioning ok. shows in 'devices' list but not in 'computer' list. good chance corruption due to incorrect removal process unplugging the USB as well.
tried WD's software , SEA tool, and thru computer using disc mgt. disc showed as unallocated etc.. win disc mgt allows for change to MBR or GUID. tried to fix it back to MBR, kept getting cyclical redundancy! no easy cure here.will accept doing it to GUID and ends up with simple disc 1, RAW,( unformatted). wants to format b4 use. from here cant seem to get anywhere. when HDD unplugged and re-used, i find its gone back to unallocated!! not holding the previous setting.
looks like badly corrupted drive, no partititon, . have tried CMD as administrator, CHKDSK...wouldnt do as said RAW. populate volume doesn't do anything.

Currently.... Found your software ( cgs) and tried. seems to go.... recognises the ext HDD, analyses, search finds a 1/2 dozen read errors. chose linux and a 50% split ( 335G, 312G) disc (start-finish) . went for FAT 32.
all seems to go ok. funny thing is, still cant seem to use HDD even though it looks like i have a nice 1/2 partiton and FAT 32 all set up.
i think i have followed correct process, but maybe HDD too far gone if your system relies on recovering settings.
am open for suggestions. i dont care about recovering any old data, only to get the HDD usable for store... i have logs. running out of options except to donate it to anyone who likes a challenge!


Sponsored links

User avatar
Site Admin
Posts: 4691
Joined: 18 Feb 2012, 15:08
Location: Le Perreux Sur Marne, France

Re: damaged WD5000 ext HDD  Topic is solved

#2 Post by cgrenier » 21 May 2018, 06:09

CRC error are due to bad sectors. It can not be repaired. The problem can be hidden for some time using the spare sectors (SMART support need to be enabled) but it's not recommended.
You really should use another disk.

Posts: 2
Joined: 20 May 2018, 03:54
Location: australia

Re: damaged WD5000 ext HDD

#3 Post by Mike1949 » 23 May 2018, 01:54

Many thanks for feedback cgr. I'm not a IT geek, so assume "CRC" error you refer to is cyclical redundancy. I have read about bad sectors (wiki) and SMART it seems possible to recover by remap and zero write to whole drive or shifting to remaining spare (good) sectors as you mentioned possible. I dont think the hdd disc has any physical damage as its seemed to go/run fine when bieng interrogated by the analyses (search) component of your testdisc. FYI, that process found about 4 read errors that i saw. sectors may be 'marked' by now as well and i think i may have also done a format at one stage as well. as the loss of this old style ext HDD I have will not be a big problem and SMART is not recommended, then its graveyard for the hdd.
Many thanks, have learned valuable lesson when 'tinkering'!
MG. :D


Who is online

Users browsing this forum: No registered users and 3 guests