UNraid - XFS partition unmountable

Using TestDisk to repair the filesystem
Forum rules
When asking for technical support:
- Search for posts on the same topic before posting a new question.
- Give clear, specific information in the title of your post.
- Include as many details as you can, MOST POSTS WILL GET ONLY ONE OR TWO ANSWERS.
- Post a follow up with a "Thank you" or "This worked!"
- When you learn something, use that knowledge to HELP ANOTHER USER LATER.
Before posting, please read https://www.cgsecurity.org/testdisk.pdf
Post Reply
Message
Author
phuketmymac
Posts: 3
Joined: 10 Apr 2018, 07:33

UNraid - XFS partition unmountable

#1 Post by phuketmymac » 04 Jun 2018, 04:45

Hello,

We have this UNraid server from a customer where 2 of his XFS drives became unmountable.
The 1st one could be repaired with xfs_repair.
The 2nd one won't giving us the error:

Sorry, could not find valid secondary superblock
Exiting now.

Can we use testdisk to try recover the partition somehow?
If yes, please can you give any recommendation?

Thanks in advance.

Sponsored links

User avatar
cgrenier
Site Admin
Posts: 4292
Joined: 18 Feb 2012, 15:08
Location: Le Perreux Sur Marne, France
Contact:

Re: UNraid - XFS partition unmountable

#2 Post by cgrenier » 04 Jun 2018, 20:37

May the second partition have been using brtfs ? It looks like some unraid users are using it instead of XFS.

phuketmymac
Posts: 3
Joined: 10 Apr 2018, 07:33

Re: UNraid - XFS partition unmountable

#3 Post by phuketmymac » 05 Jun 2018, 04:56

Well to my customer, it could have been only XFS or Reiserfs.
Since they already tried on their own to repair the filesystem with the resierfschk command, it could be that the command wrote some info on the disk using the option "--rebuild-sb" , screwing the partition.
But if that's the case, the disk should now been seen as Reiserfs disk?!

Doing a "file -s /dev/md2" give XFS as the file system.

Do you believe that, at this point, photorec will give a better result than testdisk?

Thanks for your help.

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests