Page 1 of 1

MFT is corrupt, NTFS is inconsistent

Posted: 25 Aug 2018, 14:09
by hquality
Background: my external drive is encrypted, filesystem NTFS, had no problems for a long time.
After some time I plugged it into windows, decrypted it, did my work and shut down the windows system without any errors.
It turned out that something went wrong here: one day later I tried to use that device in Ubuntu, entered my password to decrypt it and after that i ran into problems:

Code: Select all

MFT is corrupt, cannot read its unmapped extent record 17
Note : chkdsk cannot fix this, try ntfsfix
Inode is corrupt (0): Input/output error
Failed to load runlist for $MFT/$DATA.
highest_vcn = 0x3, last_vcn - 1 = 0x502bd
Failed to load $MFT: Input/output error
Failed to mount '/dev/mapper/truecrypt2': Input/output error
NTFS is either inconsistent, or there is a hardware fault, or it's a
SoftRAID/FakeRAID hardware. In the first case run chkdsk /f on Windows
then reboot into Windows twice. The usage of the /f parameter is very
important! If the device is a SoftRAID/FakeRAID then first activate
it and mount a different device under the /dev/mapper/ directory, (e.g.
/dev/mapper/nvidia_eahaabcc1). Please see the 'dmraid' documentation
for more details.
Back in Windows I'am able to decrypt my drive, but I can't access my files: the file or directory is corrupted and unreadable.

What I've tried so far:
Windows 10: chkdsk S: /f while S: is the mounted decrypted drive. Mounted drive is now empty, rebooted twice, still empty, Recuva sees many files, but unfortunately the structure is gone. The structure is very important for me, so I have to find another way and did a dd again from original to test drive without chkdsk this time. Now even without chkdsk Recuva detects my files. Anyway, I need the structure. And this is where TestDisk comes in i think.

Now I've started TestDisk / Create / [select device] / now None is selected. Is this correct? If I use None and press enter, NTFS is detected in the next screen.
What is to be done in my case? If I choose 'List', TestDisk crashes. Should I use Intel and go on with Analyse in the previous screen?

Best regards

Re: MFT is corrupt, NTFS is inconsistent

Posted: 27 Aug 2018, 05:45
by cgrenier
Does TestDisk 7.1-WIP also crash if you try to list the files from S: ?