WD 250GB shows as 2047GB | can't read boot sector and backup

Using TestDisk to repair the filesystem
Forum rules
When asking for technical support:
- Search for posts on the same topic before posting a new question.
- Give clear, specific information in the title of your post.
- Include as many details as you can, MOST POSTS WILL GET ONLY ONE OR TWO ANSWERS.
- Post a follow up with a "Thank you" or "This worked!"
- When you learn something, use that knowledge to HELP ANOTHER USER LATER.
Before posting, please read https://www.cgsecurity.org/testdisk.pdf
Posts: 1
Joined: 29 Dec 2018, 16:04

WD 250GB shows as 2047GB | can't read boot sector and backup

#1 Post by bludreid »

Hi everyone,

I'm faced with an issue with my WD2500BEVT 250GB hard drive. This is a laptop internal hard drive that I've used as external with an enclosure and has been using it for quite a long time without problems. Last time, my sister returned it by throwing it to me but missed me and it bounced off the couch (I know, she's an idiot) and hit the floor. Panicking, I immediately checked it on my Windows 7 laptop and was not showing on My Computer, I opened Disk Management and it was showing as 2048 GB Unallocated "Unknown" and "Not Initialized". I tried to initialize it but received an error "Data error (cyclic redundancy check)".
Disk Management.png
Disk Management.png (68.58 KiB) Viewed 553 times
I've ran testdisk 7.0 but it can't seem to detect the partition. It says "ntfs_boot_sector: Can't read boot sector. Sector: Bad" and the same goes for the backup. Sectors are identical, however.
testdisk.png (32.62 KiB) Viewed 553 times
Now I've been running Rebuild BS for about an hour and seems to be stuck (I can't move the cursor), but I know something is happening because the enclosure light is blinking as if accessing the drive.
Enclosure blink.jpg
Enclosure blink.jpg (83.36 KiB) Viewed 553 times
Can anyone help?

Sponsored links

User avatar
Site Admin
Posts: 5277
Joined: 18 Feb 2012, 15:08
Location: Le Perreux Sur Marne, France

Re: WD 250GB shows as 2047GB | can't read boot sector and backup

#2 Post by cgrenier »

You should try to clone the disk using ddrescue as described in https://www.cgsecurity.org/testdisk.pdf Once it's done, disconnect the damaged fisk and use TestDisk on the clone or the disk image.
If ddrescue failed, you will have to contact a data recovery company.