Looking for QNAP (TS-932x) ARM/aarch64 binaries of TestDisk and Photorec Topic is solved

Using PhotoRec to recover lost data
Forum rules
When asking for technical support:
- Search for posts on the same topic before posting a new question.
- Give clear, specific information in the title of your post.
- Include as many details as you can, MOST POSTS WILL GET ONLY ONE OR TWO ANSWERS.
- Post a follow up with a "Thank you" or "This worked!"
- When you learn something, use that knowledge to HELP ANOTHER USER LATER.
Before posting, please read https://www.cgsecurity.org/testdisk.pdf
Posts: 1
Joined: 09 Feb 2021, 18:45

Looking for QNAP (TS-932x) ARM/aarch64 binaries of TestDisk and Photorec

#1 Post by benhainesuk »

Hi all,

a few days ago I foolishly managed to delete a large collection of files on my QNAP TS-932X NAS which runs a Annapurna Labs ARM A-57 Cortex CPU. I have tried downloading the Marvell 88F628x ARM release, but it won't execute/run.

I'm hoping someone has managed to compile a version of Photorec for ARMv8 based CPUs they would be willing to share.

I should add that I have tried a large number of compiled versions for aarch64 (e.g. http://rpmfind.net/linux/rpm2html/searc ... (aarch-64)), however none are static builds and all require additional libraries which I've struggled to make work.

Many thanks, Ben

Sponsored links

User avatar
Site Admin
Posts: 5352
Joined: 18 Feb 2012, 15:08
Location: Le Perreux Sur Marne, France

Re: Looking for QNAP (TS-932x) ARM/aarch64 binaries of TestDisk and Photorec

#2 Post by cgrenier »

I don't have access to a QNAP using an aarch64 processor but I have tried to cross-compiled a suitable version.
Can you try https://www.cgsecurity.org/testdisk-7.2 ... nu.tar.bz2 ?

Code: Select all

cd /tmp
wget https://www.cgsecurity.org/testdisk-7.2-WIP.aarch64-QNAP-linux-gnu.tar.bz2
tar xjf testdisk-7.2-WIP.aarch64-QNAP-linux-gnu.tar.bz2
cd testdisk-7.2-WIP
Be careful to store the recovered files on a remote share to avoid overwriting lost files. Avoid FAT32 for the destination as FAT32 doesn't handle file bigger than 4 GB and may trigger an error "Not enough free space".

Posts: 1
Joined: 02 May 2021, 19:57

Re: Looking for QNAP (TS-932x) ARM/aarch64 binaries of TestDisk and Photorec

#3 Post by wout »

thanks @cgrenier!

I confirm this new version works on my QNAP TS-228A.

For anyone coming across this forum, as I didn't have a big enough disk handy, I created an Azure Storage account, and mounted the blob container using HybridSync. The mountpoint is then `/share/external/.cm/0/(randomguid)`. I suppose it works the same way using an S3 bucket or similar.

Using Photorec, however I couldn't seem to choose this hidden folder (`.cm`) as recovery destination, so I made a normal symlink to that folder.

Thanks a bunch!