Page 1 of 1

Help! Arrow keys don't work

Posted: 16 Dec 2012, 23:36
by popbelly
The arrow keys in photorec do not work for me. Nothing happens when I press them. The program responds to regular character keys such as 'q' and '2'.

I've tried with photorec 6.13 and 6.14. I run with sudo. My computer is an Intel Mac OSX 10.6.8. I'm using OSX's built-in terminal app. I've tried with a USB Mac keyboard, a PS2->USB Windows keyboard and through Screen Sharing (VNC) from my MacBook Pro. I've tried with "set -o emacs" and "set -o vi".
Here is the output of the "od -c" command when I type: up_arrow return down_arrow return right_arrow return down_arrow return ctrl-d

Code: Select all

$ od -c
0000000  033   [   A  \n 033   [   B  \n 033   [   C  \n 033   [   D  \n
Which I'm pretty sure is the standard default. I have no problem with the arrow keys when I'm in vi.

UPDATE: I've also tried: a different terminal emulator (iTerm), different shells (bash, zsh, csh), from other user accounts, and remote ssh-ing into my affected Mac from my MacBook Pro. My MacBook Pro does not suffer from the arrow key problem when I use photorec locally yet it does when I use it remotely. Please help!

Re: Help! Arrow keys don't work

Posted: 23 Dec 2012, 12:38
by cgrenier
Try 4 for left, 6 for right, 8 for up and 2 for down.
Good luck